summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom v/d Brink2016-01-10 12:01:04 +0100
committerTom v/d Brink2016-01-10 12:01:04 +0100
commit295ca9f71ee4cc4496495c1702812867dcc60178 (patch)
tree7598b7fc4775a6f8b22e98c4699027d92fea94ed /PKGBUILD
downloadaur-295ca9f71ee4cc4496495c1702812867dcc60178.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3813eaf45b04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Maintainer: Tom v/d Brink <tomracing at gmail>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: ximeg <ximeg@tomcity.net>
+# Maintainer: desperat <c2h5ohzh2@o2.pl>
+# Maintainer: Mihai Coman <mihai@m1x.ro>
+# http://smath.info/file/yNr4Q/SMathStudioDesktop.0_97_5737.Mono.tar.gz
+# http://smath.info/?file=739152
+
+pkgname=smath
+pkgver=0_97_5737
+pkgrel=1
+pkgdesc="A mathematical program with many features and paper-like interface, similar to Mathcad"
+arch=('i686' 'x86_64')
+url="http://smath.info"
+license=('CCPL')
+groups=('math')
+depends=('mono')
+install=smath.install
+backup=(opt/$pkgname/settings.inf)
+source=("https://dl.dropboxusercontent.com/u/24193509/SMathStudioDesktop.0_97_5737.Mono.tar.gz"
+ "smath.desktop"
+ "https://dl.dropboxusercontent.com/u/24193509/SMathStudioLogo256.png")
+md5sums=('04cf6b3be04991dca1f94f8d6b63d4db'
+ 'af70c1bfb5bcdaab7f952339ebb2435e'
+ 'ed3720462decbcfa63df5c9d04fb03f9')
+
+package() {
+ cd "$srcdir"
+ # install program
+ install -m755 -d "$pkgdir"/opt/$pkgname/{book,examples,lang,entries,plugins,snippets}
+ install -m644 -t "$pkgdir"/opt/$pkgname/book book/*
+ install -m644 -t "$pkgdir"/opt/$pkgname/examples examples/*
+ install -m644 -t "$pkgdir"/opt/$pkgname/lang lang/*
+ install -m644 -t "$pkgdir"/opt/$pkgname *.{dll,exe}
+ install -m644 -t "$pkgdir"/opt/$pkgname/entries entries/*
+ install -m644 -t "$pkgdir"/opt/$pkgname/plugins plugins/*
+ install -m644 -t "$pkgdir"/opt/$pkgname/snippets snippets/*
+
+ # create settings file
+ touch "$pkgdir"/opt/$pkgname/settings.inf
+ chmod 664 "$pkgdir"/opt/$pkgname/settings.inf
+
+echo "#!/bin/sh
+cd /opt/smath
+mono SMathStudio_Desktop.exe \"$@\"
+" > ../$pkgname.sh
+
+ # install launcher
+ install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 "${srcdir}/smath.desktop" "${pkgdir}/usr/share/applications/smath.desktop"
+ install -Dm644 "${srcdir}/SMathStudioLogo256.png" "${pkgdir}/usr/share/pixmaps/smath.png"
+
+}