summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDea19932015-06-08 10:41:02 +0200
committerDea19932015-06-08 10:41:02 +0200
commit816aac3aaac4072c6ba11e8715d08c8e367865b2 (patch)
tree850fbb0a436cd51f3bb545ba8e1613fcd64c442b /PKGBUILD
downloadaur-816aac3aaac4072c6ba11e8715d08c8e367865b2.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3789a121b9db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dea1993 <andrea.deangelis93@gmail.com>
+
+pkgname=snake_pygame
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="A remake of classic Snake game written in Python"
+arch=('any')
+url="http://deasproject.altervista.org"
+license=('GPL2')
+depends=('python2-pygame' 'python2-numpy' 'python2-xdg')
+source=("snake_${pkgver}.7z"::"http://sourceforge.net/projects/snakepygame/files/snake_${pkgver}.7z/download")
+md5sums=('608cb6f9e925adbdbbae49d20ed660bd')
+
+package() {
+ cd "${srcdir}/snake_${pkgver}"
+
+ install -m 755 -d "${pkgdir}/usr/share/${pkgname}"
+ install -m 755 -t "${pkgdir}/usr/share/${pkgname}" "snake_pygame.py"
+
+ install -m 755 -d "${pkgdir}/usr/share/${pkgname}/Sound"
+ install -m 644 -t "${pkgdir}/usr/share/${pkgname}/Sound" Sound/*
+
+ install -m 755 -d "${pkgdir}/usr/share/${pkgname}/Immagini"
+ install -m 644 -t "${pkgdir}/usr/share/${pkgname}/Immagini" Immagini/*
+
+ install -m 755 -d "${pkgdir}/usr/share/applications/"
+ install -m 755 -t "${pkgdir}/usr/share/applications/" "snake_pygame.desktop"
+
+ install -m 755 -d "${pkgdir}/usr/bin"
+ install -m 755 -t "${pkgdir}/usr/bin/" "snake_pygame"
+} \ No newline at end of file