summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRecolic Keghart2017-10-03 22:19:09 +0800
committerRecolic Keghart2017-10-03 22:19:09 +0800
commit193cabf31337c5788ecd18678a729943919cb038 (patch)
tree6f6daf2aa8edb6972f4b644a0c6223820fafe9b9 /PKGBUILD
downloadaur-193cabf31337c5788ecd18678a729943919cb038.tar.gz
init-1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..223b4152e852
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Snakesocks Origin Developers <snakesocks@mail.com>
+# I'm really sorry but providing our name is dangerous to us. Github: https://github.com/snakesocks
+
+pkgname=snakesocks
+pkgver=1.2
+pkgrel=1
+pkgdesc="An extensible proxy which prevents some ISP from detecting network traffic."
+url="https://github.com/SnakeSocks/$pkgname"
+license=("GPL2")
+arch=("i686" "x86_64")
+depends=("glibc>=2.14")
+conflicts=("$pkgname-git")
+replaces=("$pkgname-git")
+backup=("etc/$pkgname/conf/client.conf" "etc/$pkgname/conf/server.conf")
+source=("$pkgname-$pkgver.tar.gz::$url/releases/download/v$pkgver/snakesocks-linux-$pkgver-all.tar.gz")
+sha256sums=("1283331e773e048e206a47581151660ef477db752c44b94499bfdb21514de3bd")
+
+package() {
+ export pkgdir
+ cd "$pkgver"
+ ./install.sh client
+ ./install.sh server
+}
+