summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRecolic Keghart2017-10-04 12:43:26 +0800
committerRecolic Keghart2017-10-04 12:43:26 +0800
commitee25fc5519eaddd7dce546b56b0a2f3192c565ac (patch)
treedea3b08f92267827770f1a3009c1011db047eb1f /PKGBUILD
parentf3ecc71bf6f334252e2d891b42702b7d37c66f75 (diff)
downloadaur-ee25fc5519eaddd7dce546b56b0a2f3192c565ac.tar.gz
compile_from_source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aabee71cb6e6..a9c843232acc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,25 @@
# I'm really sorry but providing our name is dangerous to us. Github: https://github.com/snakesocks
pkgname=snakesocks
-pkgver=1.2
+pkgver=1.2.1
pkgrel=1
pkgdesc="An extensible proxy which prevents some ISP from detecting network traffic."
url="https://github.com/SnakeSocks/$pkgname"
license=("GPL2")
arch=("i686" "x86_64")
depends=("glibc>=2.14")
-conflicts=("$pkgname-git")
-replaces=("$pkgname-git")
+makedepends=("boost>=1.55" "go" "cmake>=3.5" "make")
+conflicts=("$pkgname-bin")
+replaces=("$pkgname-bin")
backup=("etc/$pkgname/conf/client.conf" "etc/$pkgname/conf/server.conf")
-source=("$pkgname-$pkgver.tar.gz::$url/releases/download/v$pkgver/snakesocks-linux-$pkgver-all.tar.gz")
-sha256sums=("c1c42c35e988fb4d6e8f88533216881b40fb1b0848d0875ab21e7802b142f339")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=("f5ee3440b4a5ccf1156f821c38963a3b83a8eed366549deaf0eb2e0087869f5c")
package() {
export pkgdir
- cd "$pkgver"
- ./install.sh client
- ./install.sh server
+ cd "$pkgname-$pkgver"
+ make client # requires cmake and boost
+ make server # requires go. comment it if you dont want it.
+ make install
}