summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNils Czernia2017-04-09 19:07:14 +0200
committerNils Czernia2017-04-09 19:07:14 +0200
commit5d367500124966b4e1572b21f20048fe91c6887e (patch)
treeb82d45307306f93be3c68ea3c2bc4f9a4b8f2792 /PKGBUILD
downloadaur-5d367500124966b4e1572b21f20048fe91c6887e.tar.gz
Inital commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03188a6fc673
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nils Czernia <nils [at] czserver.de>
+
+pkgname=snap7
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="Step7 Open Source Ethernet Communication Suite"
+url="http://snap7.sourceforge.net/"
+license=("LGPL3")
+arch=('x86_64')
+source=("https://downloads.sourceforge.net/project/snap7/${pkgver}/${pkgname}-full-${pkgver}.7z")
+sha256sums=('65af129e11de4b0d942751bcd9c563f7012cae174931860c03dbb2cdf2e80ae7')
+
+build() {
+ cd "${srcdir}/${pkgname}-full-${pkgver}/build/unix/"
+ make -f x86_64_linux.mk all
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-full-${pkgver}/build/"
+
+ install -dm755 "${pkgdir}/usr/lib"
+ install -dm755 "${pkgdir}/usr/include"
+
+ cp -a bin/x86_64-linux/libsnap7.so "${pkgdir}/usr/lib/"
+}