summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBart De Vries2017-03-17 22:29:02 +0100
committerBart De Vries2017-03-17 22:29:39 +0100
commit383cd5c5aa9359c3ad6d0c82ef7ba5f7cd5d87e3 (patch)
tree193ad5e572ff48fbd2471419613073ac6d6e952b /PKGBUILD
parent8bad00dc97f95c3eb3e9a57c6e37b9fd27b8aa4e (diff)
downloadaur-383cd5c5aa9359c3ad6d0c82ef7ba5f7cd5d87e3.tar.gz
Update to upstream version 0.11.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f10dc58d547d..cb15df653ce3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Bart De Vries <devriesb@gmail.com>
pkgname=snapcast
-pkgver=0.10.0
-pkgrel=2
+pkgver=0.11.0
+pkgrel=1
pkgdesc="Synchronous multi-room audio player"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://github.com/badaix/snapcast"
@@ -17,27 +17,21 @@ conflicts=()
replaces=()
backup=('etc/default/snapserver' 'etc/default/snapclient')
options=()
-install=
+install=snapcast.install
changelog=
source=("git+https://github.com/badaix/${pkgname}.git#tag=v${pkgver//_/-}"
"${pkgname}-systemd.patch")
noextract=()
validpgpkeys=()
md5sums=('SKIP'
- '409bb645138a52462aa8800a3f1b620b')
+ '374f174354508e3a3e2ab28910a9eb5c')
prepare() {
cd "$pkgname"
patch -p1 -i "$srcdir/$pkgname-systemd.patch"
cd externals
- # submodule update barfs on vorbis which is in 0.10.0, but unused!
- # switch back to line below on next version!
- #git submodule update --init --recursive
- git submodule update --init asio
- git submodule update --init flac
- git submodule update --init ogg
- git submodule update --init popl
- git submodule update --init tremor
+ # update all submodules
+ git submodule update --init --recursive
}
build() {