summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaciek Borzecki2018-10-25 13:48:00 +0200
committerMaciek Borzecki2018-10-25 13:49:36 +0200
commit4e43dedbe20c36b6ab4d3d40906363c459a84845 (patch)
treeffafc35f520b8935ad186a748a19a8311588fad7 /PKGBUILD
parent65c3593eb09efd98050cfa186d7070b9facb0372 (diff)
downloadaur-4e43dedbe20c36b6ab4d3d40906363c459a84845.tar.gz
upgpkg: snapd 2.36-1, enable AppArmor
New upstream release. This is the first version of snapd with AppArmor enabled on Arch. Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c986effd050..c6040e1928c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,17 @@ pkgname=snapd
pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd')
optdepends=('bash-completion: bash completion support')
-pkgver=2.35.4
+pkgver=2.36
pkgrel=1
arch=('x86_64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
-makedepends=('git' 'go' 'go-tools' 'libseccomp' 'libcap' 'systemd' 'xfsprogs' 'python-docutils')
+makedepends=('git' 'go' 'go-tools' 'libseccomp' 'libcap' 'systemd' 'xfsprogs' 'python-docutils' 'apparmor')
conflicts=('snap-confine')
options=('!strip' 'emptydirs')
install=snapd.install
source=("$pkgname-$pkgver.tar.xz::https://github.com/snapcore/${pkgname}/releases/download/${pkgver}/${pkgname}_${pkgver}.vendor.tar.xz")
-sha256sums=('bd6caaa446f8bc22ebdc80d524704b74bec4f3976034742eaa2f73a6fd8c4713')
+sha256sums=('65a54a4e21419394859063e926a012f07c04a9bfb1146a28a3f48c9221331d86')
_gourl=github.com/snapcore/snapd
@@ -76,7 +76,7 @@ build() {
--prefix=/usr \
--libexecdir=/usr/lib/snapd \
--with-snap-mount-dir=/var/lib/snapd/snap \
- --disable-apparmor \
+ --enable-apparmor \
--enable-nvidia-biarch \
--enable-merged-usr
make $MAKEFLAGS
@@ -119,6 +119,7 @@ package() {
# pre-create directories
install -dm755 "$pkgdir/var/lib/snapd/snap"
install -dm755 "$pkgdir/var/cache/snapd"
+ install -dm755 "$pkgdir/var/lib/snapd/apparmor"
install -dm755 "$pkgdir/var/lib/snapd/assertions"
install -dm755 "$pkgdir/var/lib/snapd/desktop/applications"
install -dm755 "$pkgdir/var/lib/snapd/device"
@@ -137,9 +138,6 @@ package() {
install -dm700 "$pkgdir/var/lib/snapd/cache"
make -C cmd install DESTDIR="$pkgdir/"
- # move snapd-generator to systemd generators
- install -dm755 "$pkgdir/usr/lib/systemd/system-generators"
- mv "$pkgdir/usr/lib/snapd/snapd-generator" "$pkgdir/usr/lib/systemd/system-generators/"
# Install man file
mkdir -p "$pkgdir/usr/share/man/man1"
@@ -158,6 +156,4 @@ package() {
rm -fv "$pkgdir/usr/lib/snapd/snapd.core-fixup.sh"
rm -fv "$pkgdir/usr/bin/ubuntu-core-launcher"
rm -fv "$pkgdir/usr/lib/snapd/system-shutdown"
- # apparmor bits
- rm -rfv "$pkgdir"/var/lib/snapd/apparmor
}