summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraimileus2018-01-08 06:57:51 +0100
committeraimileus2018-01-08 06:58:53 +0100
commit574ee395f58c63c5dcf15e8593146f6df85d3eff (patch)
tree8b695d8bd3c215c09f8feca683324b19d153bc05 /PKGBUILD
parent53385e4838a91c232ab9ef9bf309823494dc00fa (diff)
downloadaur-574ee395f58c63c5dcf15e8593146f6df85d3eff.tar.gz
snapd - add install file from upstream/snapd-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 042019b29cad..ff6a417d390d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,14 @@ pkgname=snapd
pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd')
pkgver=2.30
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
makedepends=('git' 'go-pie' 'go-tools' 'bzr' 'libcap' 'python-docutils' 'systemd' 'xfsprogs')
checkdepends=('python' 'squashfs-tools' 'indent' 'shellcheck')
options=('!strip' 'emptydirs')
+install=snapd.install
source=("git+https://github.com/snapcore/${pkgname}.git#tag=${pkgver}")
md5sums=('SKIP')
@@ -105,6 +106,7 @@ package() {
install -Dm755 "$GOPATH/bin/snap-seccomp" "$pkgdir/usr/lib/snapd/snap-seccomp"
install -Dm755 "$GOPATH/bin/snap-update-ns" "$pkgdir/usr/lib/snapd/snap-update-ns"
install -Dm755 "$GOPATH/bin/snap-exec" "$pkgdir/usr/lib/snapd/snap-exec"
+ install -Dm755 "$srcdir/$pkgname/packaging/fedora/snap-mgmt" "$pkgdir/usr/lib/snapd/snap-mgmt"
# Symlink /var/lib/snapd/snap to /snap so that --classic snaps work
ln -s var/lib/snapd/snap "$pkgdir/snap"