summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaciek Borzecki2018-02-08 16:09:39 +0100
committerMaciek Borzecki2018-02-08 16:13:49 +0100
commit57cf6441a75d1d01e0c720bdb77f875e87bd4dc7 (patch)
tree0f9070bb21cfedd573012ff5961173a882dbffe6 /PKGBUILD
parent62a03626387d3b51d7dcbcf604f359aef69db3df (diff)
downloadaur-57cf6441a75d1d01e0c720bdb77f875e87bd4dc7.tar.gz
snapd: fix build with go1.9.4
Drop all cgo/pkgconfig flags in snap-seccomp that are now rejected by go1.9.4+. Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06c8ee28d37a..ea463e52a7cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd')
optdepends=('bash-completion: bash completion support')
pkgver=2.31
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
@@ -16,8 +16,10 @@ makedepends=('git' 'go-pie' 'go-tools' 'libseccomp' 'libcap' 'systemd' 'xfsprogs
conflicts=('snap-confine')
options=('!strip' 'emptydirs')
install=snapd.install
-source=("$pkgname-$pkgver::https://github.com/snapcore/${pkgname}/archive/$pkgver.tar.gz")
-sha256sums=('973e7e8098f5780d71a0633a0fa7c3371ef7fb7ae120d464b2e25af9588c1f89')
+source=("$pkgname-$pkgver::https://github.com/snapcore/${pkgname}/archive/$pkgver.tar.gz"
+ "0001-cmd-snap-seccomp-drop-link-flags-that-will-be-reject.patch")
+sha256sums=('973e7e8098f5780d71a0633a0fa7c3371ef7fb7ae120d464b2e25af9588c1f89'
+ 'ba4591f70b032b5e6f63d251cf6463ef93f3b963b8f19aac098b4c7dbed0309d')
_gourl=github.com/snapcore/snapd
@@ -33,8 +35,7 @@ prepare() {
mkdir -p "$(dirname "$GOPATH/src/${_gourl}")"
ln --no-target-directory -fs "$srcdir/$pkgname-$pkgver" "$GOPATH/src/${_gourl}"
- # Patch snap-seccomp build flags not to link libseccomp statically.
- sed -i -e 's/-Wl,-Bstatic -lseccomp -Wl,-Bdynamic/-lseccomp/' "cmd/snap-seccomp/main.go"
+ patch -Np1 -i "${srcdir}/0001-cmd-snap-seccomp-drop-link-flags-that-will-be-reject.patch"
}
build() {