summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaciek Borzecki2019-10-05 15:36:03 +0200
committerMaciek Borzecki2019-10-05 15:36:03 +0200
commit8a0e6187985d6f646b8ba6545e563e84bf57c28c (patch)
tree07c3c428d00379a0ad1945f595e3d3a290de3207 /PKGBUILD
parentdc0b48fb4dd6500aac6232296ce34c9f21f96098 (diff)
downloadaur-8a0e6187985d6f646b8ba6545e563e84bf57c28c.tar.gz
upgpkg: snapd 2.42-2
Unset GO111MODULE for the build. It is possible that GO111MODULE=on was set by the user and it was seen to break the build like this: ==> Starting build()... *** Setting version to '2.42-1' from user. go: finding github.com/snapcore/snapd latest can't load package: package github.com/snapcore/snapd/cmd/snap: no matching versions for query "latest" Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a5ad0f77eb5..6ec54f868e15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd' 'apparmor')
optdepends=('bash-completion: bash completion support')
pkgver=2.42
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
@@ -37,6 +37,9 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
export GOPATH="$srcdir/go"
+ # snapd does not use modules, setting GO111MODULE=on in the environment breaks
+ # the build
+ unset GO111MODULE
export CGO_ENABLED="1"
export CGO_CFLAGS="${CFLAGS}"
@@ -87,6 +90,9 @@ build() {
package() {
cd "$pkgname-$pkgver"
export GOPATH="$srcdir/go"
+ # snapd does not use modules, setting GO111MODULE=on in the environment breaks
+ # the build
+ unset GO111MODULE
# Install bash completion
install -Dm644 data/completion/snap \