summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThandi M2022-11-18 01:27:32 -0500
committerThandi M2022-11-18 01:27:32 -0500
commit993972473808b5c657662df65a9e2870f0014f1e (patch)
tree713a2094e65f6c533a52c2951387885f682f38a6 /PKGBUILD
parent461a3e31c4b3412975d74f5fb9d55bf349f3f136 (diff)
downloadaur-snapd-glib-git.tar.gz
Updated to meson
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb378b17e322..ba544bc83e80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=snapd-glib-git
pkgname=snapd-glib-git
pkgdesc="Library to allow GLib/Qt based applications access to snapd, the daemon that controls Snaps"
depends=( 'libsoup' 'json-glib')
-pkgver=1.44.r6.g44ae271
+pkgver=1.63.r1.gba68fa1
pkgrel=1
arch=('x86_64')
url="https://github.com/snapcore/snapd-glib"
@@ -25,12 +25,16 @@ pkgver() {
}
build() {
- cd "$_pkgbase"
- ./autogen.sh --disable-silent-rules --enable-gtk-doc --prefix=/usr
- make $MAKEFLAGS
+ cd "$_pkgbase"
+ meson _build --prefix=/usr
+ ninja -C _build install
+# ./autogen.sh --disable-silent-rules --enable-gtk-doc --prefix=/usr
+# make $MAKEFLAGS
}
package_snapd-glib-git() {
- cd "$_pkgbase"
- make install DESTDIR="$pkgdir"
+ cd "$_pkgbase"
+ meson _build --prefix=/usr
+ ninja -C _build install
+# make install DESTDIR="$pkgdir"
}