summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2021-03-26 10:22:43 +1100
committerMatthew Gamble2021-03-26 10:22:43 +1100
commit00f8289cc66e7fd93f7193b5d648338bad579a66 (patch)
treec61c71b1785dc7569f071a386a47f7d6319e2da1 /PKGBUILD
parent46ce0cec730099f9df08fbcb91da6b4041eff239 (diff)
downloadaur-00f8289cc66e7fd93f7193b5d648338bad579a66.tar.gz
Apply patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58a3f2cadb3a..d582fe4d5cf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="snapdrop"
pkgver=2021.03.10
-pkgrel=1
+pkgrel=2
_githash="fad4632eb903ea6de9ecbec90df0ac6bd7410e68"
pkgdesc="A Progressive Web App for local file sharing"
url="https://github.com/RobinLinus/snapdrop"
@@ -13,14 +13,19 @@ makedepends=("npm")
source=(
"https://github.com/RobinLinus/snapdrop/archive/${_githash}.tar.gz"
"example-nginx.conf"
+ "customise-server-host-addr.patch"
)
sha256sums=(
"8886ae45aa5910606c8125e27cc589ae26fe162eedc11a396ca864f4788f2c2a"
"a20b5daf7e2b49d0dc54e93911e22b2fea244ecf2ef3ee58960e3c2aacde586a"
+ "c91545d65af2bfd6f09e05c7263b00340a98870ee9f3ded7447891e56b296fb6"
)
prepare() {
- cd "snapdrop-${_githash}/server"
+ cd "snapdrop-${_githash}"
+ patch -p1 < "${srcdir}/customise-server-host-addr.patch"
+
+ cd "server"
npm ci
}