summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBitals2023-09-13 21:45:23 +0400
committerBitals2023-09-13 21:45:23 +0400
commit3a43d1b011f5f6418dd0f88fbfd77bca04311911 (patch)
treeee54e0f63c0d9c276395c4c9274f40f446fd4e2f /PKGBUILD
parentac728d3ba565ff557dc0e059ca73e4da283b0962 (diff)
downloadaur-3a43d1b011f5f6418dd0f88fbfd77bca04311911.tar.gz
Update to 7.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 991e35a10f1a..88981788158a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Based on snapgene-viewer package by Antony Lee <anntzer dot lee at gmail dot com>
-# Maintainer: Matthijs Tadema <M dot J dot Tadema at gmail dot com>
+# Maintainer: Bitals <me at bitals dot xyz>
+# Co-Maintainer: Matthijs Tadema <M dot J dot Tadema at gmail dot com>
# Co-Maintainer: Lorenzo Gaifas <brisvag at gmail dot com>
-# Co-Maintainer: Bitals <me at bitals dot xyz>
pkgname=snapgene
-pkgver=7.0.0
+pkgver=7.0.2
_pkgver_major=$(cut -d '.' -f 1 <<<"$pkgver")
_pkgver_major_middle=$(cut -d '.' -f 1-2 <<<"$pkgver")
pkgrel=1
@@ -13,7 +13,7 @@ url='http://www.snapgene.com/products/snapgene/'
license=('custom')
# A valid licence is required to use the full version of snapgene
source=("https://cdn.snapgene.com/downloads/SnapGene/"$_pkgver_major".x/"$_pkgver_major_middle"/"$pkgver"/snapgene_"$pkgver"_linux.rpm")
-sha512sums=('e6adea927b96c8adfc9675d682cf8d1f4f6cd2be11d8039fe6f357c7ae49c1142c3dbcb284aba68d40362d4f73a4b70f1c1cf747accb36b4112ecd09e28901d2')
+sha512sums=('517fb1812508d9457a0f75e746a3923e72ed314df5ba8ddf504220442ad9d08dd9a8b14c7d078306ba68f0b391f1f1ce08551e29394876fa3883267cce3b21fe')
package() {
cd "$pkgdir"
@@ -26,6 +26,9 @@ package() {
# locales, so we just set LANG=C.
LANG=C /opt/gslbiotech/snapgene/snapgene.sh
EOF
+
+ sed -i 's`${INSTALLED_DIR}/snapgene "$@"`QT_QPA_PLATFORM="xcb" ${INSTALLED_DIR}/snapgene "$@"`' "$pkgdir/opt/gslbiotech/snapgene/snapgene.sh"
+
chmod a+x "$pkgdir/usr/bin/snapgene"
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"