summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntony Lee2020-10-07 19:13:02 +0200
committerAntony Lee2020-10-07 19:13:21 +0200
commit9050db9f65b6c72774c32361e6d191af6f623548 (patch)
tree38af3ba94ba09c3287db8a1918f3312acf3ab898 /PKGBUILD
parentfacc9f75cdf78c26b3e0c3f0a43f294c7d80aa07 (diff)
downloadaur-9050db9f65b6c72774c32361e6d191af6f623548.tar.gz
Update to 5.1.7.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fde52cb5d557..d4cf231518d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
pkgname=snapgene-viewer
+pkgver=5.1.7
pkgrel=1
pkgdesc='Software for plasmid mapping, primer design, and restriction site analysis'
arch=('x86_64')
@@ -7,9 +8,12 @@ url='http://www.snapgene.com/products/snapgene_viewer/'
license=('custom')
_dlurl="https://www.snapgene.com/local/targets/viewer_download.php?os=linux_rpm&majorRelease=latest&minorRelease=latest"
source=("$(curl --silent --head --location "$_dlurl" | grep -Po 'Location: \K.*rpm' | tail -n1 )")
-pkgver="$(grep -Po '\d(\d|\.)+\d' <<< "$source" | tail -n1)"
sha512sums=('SKIP')
+pkgver() {
+ grep -Po '\d(\d|\.)+\d' <<< "$source" | tail -n1
+}
+
package() {
cd "$pkgdir"
cp -r "$srcdir/opt" "$pkgdir"