summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrançois Guerraz2018-10-18 09:22:36 +0100
committerFrançois Guerraz2018-10-18 09:22:36 +0100
commit529fb6d6f22f3dd7a69758094586640d4b5c45ba (patch)
tree43b9b86e86a12d625e8552d1820855d17c7f0c8f /PKGBUILD
parente7f8a3c572d892196a8f6678ea50844e3870ad15 (diff)
downloadaur-529fb6d6f22f3dd7a69758094586640d4b5c45ba.tar.gz
Fix 64bit build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa86e9d9a922..cfd1669c8bbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: François Guerraz <kubrick@fgv6.net>
pkgname=snaphu
pkgver=1.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Statistical-Cost, Network-Flow Algorithm for Phase Unwrapping"
arch=('x86_64')
url="https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/"
@@ -17,9 +17,16 @@ backup=()
options=()
install=
changelog=
-source=( "https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/$pkgname-v$pkgver.tar.gz" )
+source=( "https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/$pkgname-v$pkgver.tar.gz"
+ 'fix-64-bit-segfault.patch' )
noextract=( )
-sha256sums=('30e7be7889fc2d2ce8606de01a29f2d908de5e8eb8e32619cf6d2deff9186eb7')
+sha256sums=( '30e7be7889fc2d2ce8606de01a29f2d908de5e8eb8e32619cf6d2deff9186eb7'
+ '75b163cb6f2ba5de3a240d5d853c25d92431b9591de2ab9eedb81c0337a2704b' )
+
+prepare() {
+ cd ${pkgname}-v${pkgver}
+ patch -p1 < ${srcdir}/fix-64-bit-segfault.patch
+}
build() {
cd ${pkgname}-v${pkgver}/src/