summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZesko2022-08-28 11:54:29 +0200
committerZesko2022-08-28 11:54:29 +0200
commitd575ee8e936e51d4e9e6fdc41a0c5643aeb61ad1 (patch)
tree1e7b83c2cd8a45586214159c5e188a7545778e4f /PKGBUILD
parentd89ffc92d3570d90fc9dd124c5caffa6d9339282 (diff)
downloadaur-d575ee8e936e51d4e9e6fdc41a0c5643aeb61ad1.tar.gz
Fixed PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c7a9a95044ed..3094eba7de68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-_pkgname=snapper-snapshot-notification
-pkgname="${_pkgname}-git"
-pkgver=1.0.0
+# Maintainer: Zesko
+pkgname=snapper-snapshot-notification-git
+pkgver=r4.94a129c
pkgrel=1
pkgdesc="The Desktop notification will appear when booting into Btrfs snapshot using Overlayfs."
arch=("any")
-url="https://gitlab.com/Zesko/${_pkgname}.git"
+url="https://gitlab.com/Zesko/snapper-snapshot-notification.git"
license=("GPL3")
-makedepends=('git' 'libnotify')
-provides=("snapper-snapshot-notification")
+depends=('bash' 'libnotify')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=(git+${url})
-sha256sums=("SKIP")
+sha1sums=("SKIP")
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- install -dv "${pkgdir}/usr/bin"
- install -dv "${pkgdir}/etc/xdg/autostart"
- cd "$srcdir/$_pkgname"
- cp usr/bin/snapper-detects-snapshot $pkgdir/usr/bin/
- cp etc/xdg/autostart/snapper-detects-snapshot.desktop $pkgdir/etc/xdg/autostart/
+ cd "$srcdir/${pkgname%-git}"
+ cp -vr usr etc "$pkgdir"
}