summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Schweikert2015-06-16 13:43:14 +0200
committerFlorian Schweikert2015-06-16 13:43:14 +0200
commit03700ad73cd7a8b9664c3bbbf260c89713937852 (patch)
tree01049aa531dde2580ab1a0550f8fe49b17bab2bf /PKGBUILD
downloadaur-03700ad73cd7a8b9664c3bbbf260c89713937852.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e52ea02ecf99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Florian Schweikert <aur@ist-total.org>
+pkgname=sndcut
+pkgver=1.0
+pkgrel=1
+pkgdesc="Let's you generated LPs that you can laser cut from audio files.
+ sndcut is a program the generates LP records from audio files - it generates a SVG file that you can laser cut."
+arch=('x86' 'x86_64')
+url="https://github.com/kallaballa/sndcut"
+license=('GPL2')
+depends=('libsndfile' 'libsamplerate' 'boost-libs')
+makedepends=('boost')
+source=(https://github.com/kallaballa/$pkgname/archive/v$pkgver.zip)
+sha1sums=('162f8191e81e374742be6e9117f8a9c97f29bfdf')
+
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+}