summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThiago L. A. Miller2021-12-13 20:03:44 -0300
committerThiago L. A. Miller2021-12-13 20:03:44 -0300
commitb37fcc600ef39e30cfa86e89df2d51117c9cb4f7 (patch)
tree113e465ba59f5895a4bf779cf549265d94729918 /PKGBUILD
parentaa2ca11ef0576d889a9dba9f2f7211b9ea9b0bd8 (diff)
downloadaur-sniffles.tar.gz
Release 1.0.12
Add '-DCMAKE_CXX_FLAGS=-std=c++11' in order to avoid compilations issues. For some reason, Sniffles does not update the version string, than the binary is created inside a folder Sniffles-1.0.11 - instead of Sniffles-1.0.12. That is why the variable '_pkgver_prev' is used to hold the previous version and get ride of this bug.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2a94db25e29..1247cccb1179 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Thiago L. A. Miller <thiago_leisrael@hotmail.com>
_pkgname=Sniffles
pkgname=sniffles
-pkgver=1.0.11
+pkgver=1.0.12
+_pkgver_prev=1.0.11
pkgrel=1
pkgdesc="Structural variation caller using third generation sequencing"
arch=('x86_64')
@@ -10,8 +11,8 @@ license=('MIT')
depends=('gcc-libs')
makedepends=('cmake')
options=('!emptydirs')
-source=("$_pkgname-$pkgver.tar.gz"::"https://github.com/fritzsedlazeck/Sniffles/archive/$pkgver.tar.gz")
-md5sums=('a35303969680571ad821eeba3cd61541')
+source=("$_pkgname-$pkgver.tar.gz"::"https://github.com/fritzsedlazeck/Sniffles/archive/refs/tags/v$pkgver.tar.gz")
+md5sums=('51e5f512eb8744c152973d7ae757d484')
build() {
cd "$_pkgname-$pkgver"
@@ -20,6 +21,8 @@ build() {
cmake \
-DCMAKE_COLOR_MAKEFILE:BOOL='ON' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_CXX_FLAGS='-std=c++11' \
-Wno-dev \
..
make
@@ -28,7 +31,7 @@ build() {
package() {
cd "$_pkgname-$pkgver"
install -Dpm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dpm755 "bin/$pkgname-core-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dpm755 "bin/$pkgname-core-$_pkgver_prev/$pkgname" "$pkgdir/usr/bin/$pkgname"
}
# Local Variables: