summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEthan Pailes2020-12-17 08:55:48 -0500
committerEthan Pailes2020-12-17 12:20:47 -0500
commit6a8ad581d09f82a311023f55c49dfcf0b2cf4e51 (patch)
tree7f54eeeac3e9c7c6c5c7e59fed5576324485e97e /PKGBUILD
parentd4a049c6ad1e5bc6e62ea3bf6f8d5da3aa4964a9 (diff)
downloadaur-6a8ad581d09f82a311023f55c49dfcf0b2cf4e51.tar.gz
bump version to 1.2.10
This patch bumps the version to 1.2.10. It also starts checking the gpg signatures that snowflake provides.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 18 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffdc2d2bb23d..541365a019d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,35 @@
# Maintainer: D. Can Celasun <can[at]dcc[dot]im>
+# Co-Maintainer: Ethan Pailes ethan[at]pailes[dot]org
+
+# To be able to verify the gpg signatures run:
+# ```
+# gpg --keyserver hkp://keys.gnupg.net --recv-keys 37C7086698CB005C EC218558EABB25A1
+# printf "trusted-key 37C7086698CB005C\ntrusted-key EC218558EABB25A1\n" >> ~/.gnupg/gpg.conf
+# ```
pkgname=snowflake-client
-pkgver=1.1.82
+pkgver=1.2.10
pkgrel=1
epoch=1
pkgdesc="Snowflake Database command line client (snowsql)"
arch=('x86_64')
url="http://www.snowflake.net/"
license=('custom: commercial')
-depends=(gcc-libs)
-source=(${pkgname}-${pkgver}.sh::http://s3-us-west-2.amazonaws.com/sfc-snowsql-updates/bootstrap/1.1/linux_x86_64/snowsql-${pkgver}-linux_x86_64.bash)
-md5sums=('e93cc95e21576b63d013e7c2e03e2b35')
+depends=('gcc-libs')
+source=(
+ "${pkgname}-${pkgver}.bash::https://sfc-repo.snowflakecomputing.com/snowsql/bootstrap/$(echo ${pkgver} | awk -F. '{print $1 "." $2}')/linux_x86_64/snowsql-${pkgver}-linux_x86_64.bash"
+ "${pkgname}-${pkgver}.bash.sig::https://sfc-repo.snowflakecomputing.com/snowsql/bootstrap/$(echo ${pkgver} | awk -F. '{print $1 "." $2}')/linux_x86_64/snowsql-${pkgver}-linux_x86_64.bash.sig"
+)
+sha256sums=(
+ '0b7e620efab22df2a22bc80bae81544628a2eb4117a76ec109cfead6e8334c3c'
+ 'f5ecd6ffe307f559c8041c54f57ce4c93e408d6828e573a2411d39d7f7257725'
+)
package() {
# Stop Snowflake installer from modifying shell profile
local tmp="$(mktemp)"
- SNOWSQL_DEST="${pkgdir}" SNOWSQL_LOGIN_SHELL="${tmp}" sh "${pkgname}-${pkgver}.sh"
+ SNOWSQL_DEST="${pkgdir}" SNOWSQL_LOGIN_SHELL="${tmp}" sh "${pkgname}-${pkgver}.bash"
install -Dm755 "${pkgdir}/snowsql" "${pkgdir}/usr/bin/snowsql"
rm -f "${pkgdir}/snowsql"