summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Krenek (Mikos)2016-08-18 02:00:12 +0200
committerMichal Krenek (Mikos)2016-08-18 02:00:12 +0200
commit1f6bff461f94a6f3b67c20dc4c04b043a07a0ca7 (patch)
treeb624f6d01dc36dfe0aa18e720e45191ecb13ccd5 /PKGBUILD
downloadaur-soapyhackrf-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f09954423a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Michal Krenek (Mikos) <m.krenek@gmail.com>
+
+pkgname=soapyhackrf-git
+pkgver=r51.051ad65
+pkgrel=1
+epoch=2
+pkgdesc="SoapySDR plugin for HackRF"
+arch=('any')
+url="https://github.com/pothosware/SoapyHackRF"
+license=('GPLv3')
+depends=('soapysdr' 'hackrf')
+makedepends=('git')
+provides=('soapyhackrf')
+conflicts=('soapyhackrf')
+source=(${pkgname}::"git+https://github.com/pothosware/SoapyHackRF.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ make -j4
+}
+
+package() {
+ make -C "${srcdir}/${pkgname}/build" DESTDIR="${pkgdir}" install
+}