summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-05-07 15:09:12 +0800
committerYen Chi Hsuan2016-05-07 15:09:12 +0800
commit17974ae598594a664242559f7da0ec72ea2a2e95 (patch)
tree093f0889afa7c5b923829c5a09d235afdb5880a3 /PKGBUILD
parent354da72161758107ce9785e561ccd87996f5e086 (diff)
downloadaur-17974ae598594a664242559f7da0ec72ea2a2e95.tar.gz
Make it co-installable with socat
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 22 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2cfdbfbec89..1607848e6274 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_pkgname=socat2
pkgname=${_pkgname}-git
-pkgver=2.0.0.b6.120.g2dee720
+pkgver=2.0.0.b9.0.g7beb9b3
pkgrel=1
pkgdesc='Multipurpose relay (development version)'
url='http://www.dest-unreach.org/socat/socat-version2.html'
@@ -18,10 +18,14 @@ license=('GPL2')
arch=('i686' 'x86_64')
depends=('readline' 'openssl')
makedepends=('yodl')
-source=("$_pkgname"::"git+http://repo.or.cz/socat.git#branch=socat2")
-sha256sums=('SKIP')
-provides=('socat')
-conflicts=('socat')
+source=(
+ "$_pkgname"::"git+http://repo.or.cz/socat.git#branch=socat2"
+ sslv3.patch
+)
+sha256sums=(
+ 'SKIP'
+ '3744575806f489ad0d3673e6a397badd4b61ecbd6e474ece67b347e13c5076b5'
+)
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -29,6 +33,12 @@ pkgver() {
git describe --long --tags | sed 's/^tag-//;s/-/./g'
}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ patch -Np1 -i ../sslv3.patch
+}
+
build() {
cd "${srcdir}/${_pkgname}"
@@ -46,4 +56,11 @@ package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
+
+ # Make it co-installable with socat
+ find "${pkgdir}/usr/bin/" -type f -executable -exec mv {} {}2 \;
+ find "${pkgdir}/usr/share/man" -type f | while read manfile
+ do
+ mv $manfile ${manfile%.*}2.${manfile##*.}
+ done
}