summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-04-25 16:59:04 +0800
committerYen Chi Hsuan2017-04-25 16:59:04 +0800
commit3f737bb3e408da556f67d5616cdfa4289ba56d07 (patch)
tree9eef64d0b43a87b105133d9aa558bc23d88aca2f /PKGBUILD
parent17974ae598594a664242559f7da0ec72ea2a2e95 (diff)
downloadaur-3f737bb3e408da556f67d5616cdfa4289ba56d07.tar.gz
Target OpenSSL 1.0
OpenSSL 1.1 support is added to the master branch http://repo.or.cz/socat.git/commit/008229cb9fe60646fb04b64d3704485c32ce821b but not packported to socat2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1607848e6274..4424a78992a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,21 +11,19 @@
_pkgname=socat2
pkgname=${_pkgname}-git
pkgver=2.0.0.b9.0.g7beb9b3
-pkgrel=1
+pkgrel=2
pkgdesc='Multipurpose relay (development version)'
url='http://www.dest-unreach.org/socat/socat-version2.html'
license=('GPL2')
arch=('i686' 'x86_64')
-depends=('readline' 'openssl')
+depends=('readline' 'openssl-1.0')
makedepends=('yodl')
source=(
"$_pkgname"::"git+http://repo.or.cz/socat.git#branch=socat2"
sslv3.patch
)
-sha256sums=(
- 'SKIP'
- '3744575806f489ad0d3673e6a397badd4b61ecbd6e474ece67b347e13c5076b5'
-)
+sha256sums=('SKIP'
+ '3744575806f489ad0d3673e6a397badd4b61ecbd6e474ece67b347e13c5076b5')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -45,6 +43,8 @@ build() {
msg "Running autoconf..."
autoconf
+ CPPFLAGS="-I/usr/include/openssl-1.0" \
+ LDFLAGS="-L/usr/lib/openssl-1.0" \
./configure \
--prefix=/usr \
--mandir=/usr/share/man \