summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2019-01-20 21:52:08 +0100
committerKr1ss2019-01-20 21:52:08 +0100
commitff2f742279d06de9217e9fca5efbfd3345fa711c (patch)
tree7861342ad13f7cdd8be9c866ca4c95794abd9e57 /PKGBUILD
parent99b3770d5b55ed6c0a40222d3a6815ea33502548 (diff)
downloadaur-ff2f742279d06de9217e9fca5efbfd3345fa711c.tar.gz
cleanup PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 357d577e12a5..3a3c69583243 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-#Maintainer: Kr1ss <kr1ss.x@yandex.com>
-#Author: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
+# Maintainer: Kr1ss <kr1ss.x@yandex.com>
+# Author: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
pkgname=social-engineer-toolkit
pkgver=7.7.9
-pkgrel=3
-pkgdesc="The Social-Engineer Toolkit (SET)"
-arch=("any")
+pkgrel=4
+pkgdesc='The Social-Engineer Toolkit (SET)'
+arch=('any')
url="https://github.com/trustedsec/${pkgname}"
-license=("custom")
-makedepends=("python2")
-depends=("python2-pexpect" "python2-crypto" "python2-requests"
- "python2-pyopenssl" "python2-pefile" "impacket"
- "python2-pillow" "python2-qrcode" "python2-beautifulsoup4")
-optdepends=("metasploit")
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/trustedsec/${pkgname}/archive/${pkgver}.tar.gz"
- "setoolkit"{,.sig}
- "seproxy"{,.sig}
- "seautomate"{,.sig})
-sha512sums=('f9226428f14fb15328a83719d6636c356b331e1d9d92fd0f22438ed6c3119fe9e464e8a5838cba9fe5c1dda1d955266facc93f4325c73127085099783a7b4d77'
- '0439fe057f0fca9e2534c8c7406fde714218fb30612a1fc4e5a341aa315b52d66475f90850613cd782e4c75009fef17d1f4050818b277bd0ee3196a18156af03' 'SKIP'
- 'c0de47865d3ee9258d0731cd7122b2714c4dacba0e70370af77d3cf5a883bf59b458b284531222ab54ceee1315f890c977059365d34874a0291473d023d90d0a' 'SKIP'
- '938dd7dc1ddfb9ffed44a35211112ff0beb95dcf81113d16c44e522a1b693ede1c2d517b94aa24bb8725b3ef274af27591c1b1853bb2a56c5b9d75fdf98322c2' 'SKIP')
+license=('custom')
+makedepends=('python2')
+depends=('python2-pexpect' 'python2-crypto' 'python2-requests'
+ 'python2-pyopenssl' 'python2-pefile' 'impacket'
+ 'python2-pillow' 'python2-qrcode' 'python2-beautifulsoup4')
+optdepends=('metasploit')
+options=('!strip')
+source=("https://github.com/trustedsec/${pkgname}/archive/${pkgver}.tar.gz"
+ 'setoolkit'{,.sig}
+ 'seproxy'{,.sig}
+ 'seautomate'{,.sig})
+sha256sums=('267b2efa0470f0da9f6d53414f9a433aaea176d1a6825581ade8998924ddffd0'
+ '1901a912bc8fcc24b8a63accaa3824b50dae5f7066dbdfa83f6f9ee3e3dfdb65' 'SKIP'
+ '12014216d4249ee76b30126ab3e78862b79cab32fe663b382a579b18350a536f' 'SKIP'
+ '18976b6e8a83e158b9ca175dfebe1e98fc4085129a0b20064ec54e0bc5eda1d9' 'SKIP')
validpgpkeys=('7A194E3F7A8F867BEA8A5339023F078862ACFE50')
build() {
@@ -30,7 +31,6 @@ build() {
}
package() {
- cd "${srcdir}"
install -dm755 "${pkgdir}"/usr/{bin,share/{,doc/,licenses/}setoolkit}
install -m755 setoolkit seproxy seautomate "${pkgdir}"/usr/bin/
cd "${pkgname}-${pkgver}"