summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMantas Mikulėnas2019-09-16 19:39:56 +0300
committerMantas Mikulėnas2019-10-12 14:33:00 +0300
commit1cb23921cfb84126aa716ea2cbe8b38269bbaabe (patch)
tree57473015cd840c7157bbf95ca1556ca2e731adbc /PKGBUILD
downloadaur-1cb23921cfb84126aa716ea2cbe8b38269bbaabe.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e8704a0a68d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=softu2f
+pkgver=0.3.2.r18.ge47750b
+pkgrel=1
+pkgdesc="Software U2F HID token daemon"
+arch=(x86_64)
+source=("git+https://github.com/danstiner/rust-u2f")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd rust-u2f
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-/./'
+}
+
+build() {
+ cd rust-u2f/linux
+ cargo build --release
+}
+
+package() {
+ cd rust-u2f/linux
+
+ install -Dm 755 target/release/softu2f-user-daemon \
+ "$pkgdir"/usr/libexec/softu2f/user-daemon
+
+ install -Dm 755 target/release/softu2f-system-daemon \
+ "$pkgdir"/usr/libexec/softu2f/system-daemon
+
+ install -Dm 644 user-daemon/softu2f.service \
+ "$pkgdir"/usr/lib/systemd/user/softu2f.service
+
+ install -Dm 644 system-daemon/softu2f.service \
+ "$pkgdir"/usr/lib/systemd/system/softu2f.service
+
+ install -Dm 644 system-daemon/softu2f.socket \
+ "$pkgdir"/usr/lib/systemd/system/softu2f.socket
+
+ install -Dm 644 system-daemon/softu2f-tmpfiles.conf \
+ "$pkgdir"/usr/lib/tmpfiles.d/softu2f.conf
+}
+
+# vim: ts=2:sw=2:et