summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2022-02-23 09:37:17 -0300
committerRafael Fontenelle2022-02-23 09:37:17 -0300
commit74164610cbd22cbd50400d16bde902352197e48b (patch)
treeb205e2746c30f4ed4bc4d6ec84ce7463be15474b /PKGBUILD
parent8c28d4e1f390f75fa5de5dd1f7ce592c2b855d92 (diff)
downloadaur-74164610cbd22cbd50400d16bde902352197e48b.tar.gz
Fix ERROR Function does not take positional arguments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b59efc287593..26034d976e7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=solanum
pkgver=3.0.1.r0.g3f84b1d
-pkgrel=1
+pkgrel=2
pkgdesc="A pomodoro timer for the GNOME desktop"
arch=(x86_64)
url="https://gitlab.gnome.org/World/solanum"
@@ -10,8 +10,15 @@ depends=('libadwaita' 'gst-plugins-bad-libs')
makedepends=('rust' 'meson' 'git')
checkdepends=('appstream-glib')
_commit=3f84b1d0c46fe1a3daef2940b1d0747222023984 # tags/v3.0.1
-source=("git+$url#commit=$_commit")
-md5sums=('SKIP')
+source=("git+$url#commit=$_commit"
+ meson-drop-unused-argument.patch)
+sha256sums=('SKIP'
+ 'e2d30fb22bb8948659d909064df462bd74f44f2eb768757d041618aecb36b245')
+
+prepare() {
+ cd $pkgname
+ git apply "$srcdir/meson-drop-unused-argument.patch"
+}
pkgver() {
cd $pkgname