summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEthan Kerrick2022-08-29 23:17:59 -0400
committerEthan Kerrick2022-08-29 23:17:59 -0400
commitd80fa5003cb9609b3af13230b25230fc127166e8 (patch)
tree55e8c7f683fa92c6c755c1745edaafe382a08755 /PKGBUILD
parent0d58ea0cbbc817cce2920b7d7ba0d55f1686e06a (diff)
downloadaur-d80fa5003cb9609b3af13230b25230fc127166e8.tar.gz
new maintainer, fixed dependency versions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42a38f4c6962..3881663b726c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: Qontinuum <qontinuum.dev@protonmail.ch>
+# Maintainer : silverhikari <kerrickethan@gmail.com>
+# Contributor: Qontinuum <qontinuum.dev@protonmail.ch>
# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Fernando Carmona Varo <ferkiwi @t gmail dot com>
# Contributor: BenObiWan <benobiwan @t gmail dot com>
pkgname=solarus-git
-pkgver=1.5.3.r1139.gf0eadc40f
-pkgrel=2
+pkgver=1.5.3.r1446.g2593c31de
+pkgrel=1
pkgdesc="An open-source adventure 2D game engine (git version)"
arch=('i686' 'x86_64')
url="http://www.solarus-games.org/"
license=('GPL3')
depends=('glm'
'hicolor-icon-theme'
- 'libmodplug>=0.8.8.4'
+ 'libmodplug'
'libvorbis'
- 'luajit>=2.0'
+ 'luajit'
'openal'
'physfs'
'qt5-base'
@@ -25,7 +26,7 @@ depends=('glm'
makedepends=('git' 'cmake')
provides=('solarus')
conflicts=('solarus')
-source=($pkgname::'git+https://gitlab.com/solarus-games/solarus.git')
+source=('git+https://gitlab.com/solarus-games/solarus.git')
md5sums=('SKIP')
pkgver() {
@@ -34,18 +35,24 @@ pkgver() {
}
prepare() {
- cd $pkgname
- cmake -Wno-dev -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_C_FLAGS="$CFLAGS" -DCMAKE_CXX_FLAGS="$CXXFLAGS $CPPFLAGS" -DCMAKE_EXE_LINKER_FLAGS="$LDFLAGS" .
+ cmake -B build -S "${pkgname%-git}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ cmake --build build
}
build() {
- make -C "$pkgname"
+ cd build
+ make
}
check() {
- make -C "$pkgname" test
+ cd build
+ make
}
package() {
- make -C "$pkgname" DESTDIR="$pkgdir/" install
+ cd build
+ make DESTDIR="$pkgdir/" install
}