summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author5chdn2016-08-11 10:56:53 +0200
committer5chdn2016-08-11 10:56:53 +0200
commit657d861c8edf6cfb58281109b53990121aadba7d (patch)
tree035ece5f86bdcfeaa5bba0f2618e7755a556eb70 /PKGBUILD
downloadaur-657d861c8edf6cfb58281109b53990121aadba7d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD95
1 files changed, 95 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f53e8b684cfb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,95 @@
+# Maintainer: Afri 5chdn <aur@cach.co>
+
+pkgname=solidity-git
+pkgver=v0.3.6.r43.ge2a46b6
+pkgrel=1
+pkgdesc="The Solidity Contract-Oriented Programming Language (Including solc, lllc; from latest unstable git version)"
+arch=('i686' 'x86_64')
+depends=(
+ 'argtable'
+ 'boost'
+ 'boost-libs'
+ 'curl'
+ 'crypto++'
+ 'gmp'
+ 'jsoncpp'
+ 'leveldb'
+ 'libedit'
+ 'libjson-rpc-cpp-git'
+ 'libmicrohttpd'
+ 'miniupnpc'
+ 'ncurses'
+ 'libcl'
+ 'opencl-headers'
+ 'openssl'
+ 'python2'
+ 'qt5-base'
+ 'qt5-declarative'
+ 'qt5-quick1'
+ 'qt5-quickcontrols'
+ 'qt5-webengine'
+ 'qt5-webkit'
+ 'qt5-graphicaleffects'
+ 'readline'
+ 'snappy'
+ 'llvm'
+ 'scons'
+ 'gperftools'
+)
+makedepends=(
+ 'autoconf'
+ 'automake'
+ 'cmake'
+ 'gcc'
+ 'libtool'
+ 'yasm'
+ 'git'
+ 'clang'
+)
+groups=('ethereum')
+url="https://github.com/ethereum/solidity"
+license=('GPL')
+source=("${pkgname%-git}::git+https://github.com/ethereum/solidity")
+sha256sums=('SKIP')
+provides=(
+ 'lll'
+ 'lllc'
+ 'liblll'
+ 'solidity'
+ 'solc'
+ 'libsoldevcore'
+ 'libsolevmasm'
+ 'libsolidity'
+)
+
+pkgver() {
+ cd ${pkgname%-git}
+ git checkout -q develop
+ git pull -q
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ msg 'Updating...'
+ cd ${pkgname%-git}
+ git checkout develop
+ git pull
+ git submodule update --init --recursive
+
+ msg 'Building...'
+ mkdir -p build && pushd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+ popd
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg 'Installing...'
+ make DESTDIR="$pkgdir" install -C build
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}