summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author5chdn2016-10-09 22:06:16 +0200
committer5chdn2016-10-09 22:06:16 +0200
commit90712bb42e78e514a118f4609a787cd4d3ae927b (patch)
treec784807b0ab7c776c3ccfa34aacf53c9845e957e /PKGBUILD
parent8e73cbcd7c05c4d3aba310b4c5c2bec439004c49 (diff)
downloadaur-90712bb42e78e514a118f4609a787cd4d3ae927b.tar.gz
use version string from CMakeLists.txt
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f0b081e5d66..a207351d860d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Afri 5chdn <aur@cach.co>
pkgname=solidity-git
-pkgver=v0.4.0.r59.gf52634a
+pkgver=v0.4.3.git.8572664
pkgrel=1
pkgdesc="The Solidity Contract-Oriented Programming Language (Including solc, lllc; from latest unstable git version)"
arch=('i686' 'x86_64')
@@ -40,7 +40,7 @@ provides=(
pkgver() {
cd ${pkgname%-git}
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ echo "v`grep -m1 "PROJECT\_VERSION" CMakeLists.txt | sed 's/[[:alpha:]|\_|(|[:space:]|)|\"]//g'`.git.`git log --pretty=format:%h -n 1`"
}
build() {