summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author5chdn2016-10-09 22:23:30 +0200
committer5chdn2016-10-09 22:23:30 +0200
commitda98ae7e33de922d04db19d3e2eba7999dd78fa6 (patch)
tree0bf247b75b129dcdee7e0ccd88e74343323db165 /PKGBUILD
parent90712bb42e78e514a118f4609a787cd4d3ae927b (diff)
downloadaur-da98ae7e33de922d04db19d3e2eba7999dd78fa6.tar.gz
use tr and not sed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a207351d860d..c6ff5d71bc84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,7 +40,7 @@ provides=(
pkgver() {
cd ${pkgname%-git}
- echo "v`grep -m1 "PROJECT\_VERSION" CMakeLists.txt | sed 's/[[:alpha:]|\_|(|[:space:]|)|\"]//g'`.git.`git log --pretty=format:%h -n 1`"
+ echo "v`grep -m1 "PROJECT\_VERSION" CMakeLists.txt | tr -cd '[[:digit:]].'`.git.`git log --pretty=format:%h -n 1`"
}
build() {