summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOlibia Tsati2015-10-23 00:37:03 +0300
committerOlibia Tsati2015-10-23 00:37:03 +0300
commitd74aadbc49a743e6df1f746e3c5e824d1b7bee68 (patch)
tree2eac78e8c926a90b75eb37663b20e0d61e57c76a /PKGBUILD
downloadaur-d74aadbc49a743e6df1f746e3c5e824d1b7bee68.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f06ab5497db2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=sopcast-launcher
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Sopcast Launcher allows you to open Sopcast links with a Media Player of your choice"
+arch=('any')
+url="https://github.com/jonian/sopcast-launcher"
+license=('GPL')
+groups=()
+depends=('python2-psutil' 'sopcast')
+makedepends=()
+optdepends=('vlc')
+provides=('sopcast-launcher')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://github.com/jonian/sopcast-launcher/archive/v$pkgver.tar.gz)
+noextract=()
+md5sums=('SKIP')
+
+package() {
+ mkdir -p "$pkgdir/opt"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+
+ cp -a "$srcdir/$pkgname-$pkgver" "$pkgdir/opt/sopcast-launcher"
+
+ update-desktop-database "$pkgdir/opt/sopcast-launcher"
+
+ ln -s "/opt/sopcast-launcher/sopcast-launcher.py" "$pkgdir/usr/bin/sopcast-launcher"
+ mv "$pkgdir/opt/sopcast-launcher/sopcast-launcher.desktop" "$pkgdir/usr/share/applications/sopcast-launcher.desktop"
+}