summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2020-09-27 23:37:30 +0200
committerChristopher Arndt2020-09-27 23:37:30 +0200
commit9116f39eb9798cecc2ab89e846ceb5a74a07ab73 (patch)
treeaf6cf03cf60b58bfea2654d872b2edaec93fe8cd /PKGBUILD
parent171acf3d50048239e69fed871e1d0bc56fb21f42 (diff)
downloadaur-9116f39eb9798cecc2ab89e846ceb5a74a07ab73.tar.gz
Add 'check' function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd6666eec686..393f8c25c355 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=sord
pkgname="${_pkgname}-git"
-pkgver=0.16.4.r421.61d9657
+pkgver=0.16.6.r446.3faa8cc
pkgrel=1
pkgdesc="Lightweight C library for storing RDF statements in memory (git version)"
arch=('i686' 'x86_64')
@@ -39,10 +39,15 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
- python ./waf configure --prefix=/usr
+ python ./waf configure --prefix=/usr --test
python waf build $MAKEFLAGS
}
+check() {
+ cd "${srcdir}/${_pkgname}"
+ python waf test -v
+}
+
package() {
cd "${srcdir}/${_pkgname}"