summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Phillips2018-01-29 22:59:12 -0800
committerJulian Phillips2018-01-29 22:59:12 -0800
commit861e8990a0ecb705ed605c8eafbd12f7f9d5e989 (patch)
tree6296551c69b86be02774f767b828ce77b31383b8 /PKGBUILD
parent76a70b545094b0b10eb8dfb268f63d2cfc2095a9 (diff)
downloadaur-861e8990a0ecb705ed605c8eafbd12f7f9d5e989.tar.gz
Moved nose & coverage pkgs to checkdepends. Pull Arch support from Github PR.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6fae7e1e589..4bf6f2f30382 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: chr0mag <phillips.julian AT gmail DOT com>
pkgname=sos
pkgver=3.5
-pkgrel=3
+pkgrel=4
epoch=
pkgdesc="A unified tool for collecting system logs and other debug information"
arch=('any')
@@ -13,8 +13,8 @@ depends=('python'
'python-lxml'
'xz'
'tar')
-makedepends=('python-sphinx' 'python-nose' 'python-coverage')
-checkdepends=()
+makedepends=('python-sphinx')
+checkdepends=('python-nose' 'python-coverage')
optdepends=()
provides=()
conflicts=()
@@ -24,20 +24,23 @@ options=()
install=
changelog=
_urlparsefix="0b30e8f72c3c669455209d15b1eb01de20c7d578.patch"
-source=("https://github.com/sosreport/sos/archive/$pkgver.tar.gz" "https://github.com/sosreport/sos/commit/$_urlparsefix" "arch.py")
+_archpullreq="1198.patch"
+source=("https://github.com/sosreport/sos/archive/$pkgver.tar.gz"
+ "https://github.com/sosreport/sos/commit/$_urlparsefix"
+ "https://patch-diff.githubusercontent.com/raw/sosreport/sos/pull/$_archpullreq")
noextract=()
md5sums=()
sha256sums=('f62df231dd3c86a54645989f943bac6f5fdf45ffb210f4b76b4a5cc565296902'
'acf581080bad7772f10e183d18a2d1c2cf9bd9be91ee490e38ef5c5647859d6c'
- '8a6565c1f7cd59ee9de3fc3896cafbf270a8e135e752901e8527471a7a405774')
+ 'a57c89078c6ccbb99a2b5e5ff939979f8283ec4f68aa258d743634106607b950')
validpgpkeys=()
prepare() {
cd "$pkgname-$pkgver"
# fix for: https://github.com/sosreport/sos/commit/0b30e8f72c3c669455209d15b1eb01de20c7d578
- patch sos/plugins/haproxy.py < ../../$_urlparsefix
- #add basic Arch policy
- cp ../../arch.py sos/policies
+ patch --strip=1 < ../../$_urlparsefix
+ #add basic Arch support
+ patch --strip=1 < ../../$_archpullreq
}
build() {
@@ -57,6 +60,4 @@ package() {
mkdir ${pkgdir}/usr/bin
mv ${pkgdir}/usr/sbin/sosreport ${pkgdir}/usr/bin
rmdir ${pkgdir}/usr/sbin
- #workaround for: https://github.com/sosreport/sos/issues/77
- #sed --in-place 's/#disable = rpm, selinux, dovecot/disable = rpm, selinux, dovecot, sunrpc, nfsserver, distupgrade/' ${pkgdir}/etc/sos.conf
}