summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLarzid2021-04-23 17:00:59 -0500
committerLarzid2021-04-23 17:00:59 -0500
commit49ded5bcdb87836ad04cfcda66712dc67d482421 (patch)
tree18f75d883b138b37336a4218e415c012214df2ad /PKGBUILD
parentebb8445078e3dbc11897bee09ff8247a88124c98 (diff)
downloadaur-49ded5bcdb87836ad04cfcda66712dc67d482421.tar.gz
v1.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 22 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a13f996a752..a454c295bf34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Larzid <juanitocampamocha@gmail.com>
pkgname=sotw
-pkgver=1.2.8
+pkgver=1.3.0
pkgrel=1
epoch=
pkgdesc="Shadow Of The Wyrm is a single player, traditional roguelike by Julian Day."
@@ -17,10 +17,10 @@ replaces=()
backup=()
options=()
changelog=
-source=('git+https://github.com/prolog/shadow-of-the-wyrm.git')
+source=('git+https://github.com/prolog/shadow-of-the-wyrm.git' 'https://i.imgur.com/z9QmK0X.png')
noextract=()
-md5sums=('SKIP')
-validpgpkeys=()
+md5sums=('SKIP' 'SKIP')
+validpgpkeys=('SKIP')
build() {
cd shadow-of-the-wyrm
@@ -32,8 +32,20 @@ build() {
package() {
echo "#!/bin/sh" > ${srcdir}/shadow-of-the-wyrm/sotw.sh
- echo "cd /usr/share/shadow-of-the-wyrm" >> ${srcdir}/shadow-of-the-wyrm/sotw.sh
- echo "./ShadowOfTheWyrm" >> ${srcdir}/shadow-of-the-wyrm/sotw.sh
+ echo "cd /usr/share/shadow-of-the-wyrm" > ${srcdir}/shadow-of-the-wyrm/sotw.sh
+ echo "./ShadowOfTheWyrm" > ${srcdir}/shadow-of-the-wyrm/sotw.sh
+ echo "[Desktop Entry]
+ Version=1.3.0
+ Name=Shadow Of The Wyrm
+ GenericName=SOTW
+ Type=Application
+ Comment=A single player, traditional roguelike by Julian Day.
+ Icon=sotw
+ Exec=sotw
+ Terminal=false
+ SartupNotify=false
+ Keywords=game;roguelike;
+ Categories=Game;" > ${srcdir}/sotw.desktop
chmod +x ${srcdir}/shadow-of-the-wyrm/sotw.sh
install -D -m644 ${srcdir}/shadow-of-the-wyrm/LICENSE "${pkgdir}/usr/share/licenses/shadow-of-the-wyrm/LICENSE"
install -d -m777 ${srcdir}/shadow-of-the-wyrm "${pkgdir}/usr/share/shadow-of-the-wyrm"
@@ -48,5 +60,9 @@ package() {
cp -R ${srcdir}/shadow-of-the-wyrm/licenses ${pkgdir}/usr/share/shadow-of-the-wyrm/licenses
cp -R ${srcdir}/shadow-of-the-wyrm/scripts ${pkgdir}/usr/share/shadow-of-the-wyrm/scripts
cp -R ${srcdir}/shadow-of-the-wyrm/texts ${pkgdir}/usr/share/shadow-of-the-wyrm/texts
+ mkdir ${pkgdir}/usr/share/icons/
+ mkdir ${pkgdir}/usr/share/applications/
+ cp -R ${srcdir}/z9QmK0X.png ${pkgdir}/usr/share/icons/sotw.png
+ cp -R ${srcdir}/sotw.desktop ${pkgdir}/usr/share/applications/sotw.desktop
install -D ${srcdir}/shadow-of-the-wyrm/sotw.sh ${pkgdir}/usr/bin/sotw
}