summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLarzid2019-11-27 03:54:16 -0600
committerLarzid2019-11-27 03:54:16 -0600
commit8135432c035b73b4dc8c2b17393969c5b772dedb (patch)
treea3e51adf0d7732bcaddcab774169ac0ab59b3a55 /PKGBUILD
parent599b24fa75947aaa584f2cce5af4d0accb61e428 (diff)
downloadaur-8135432c035b73b4dc8c2b17393969c5b772dedb.tar.gz
v1.1.5-Losy
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6665513117c..910a08f4ec72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Maintainer: Larzid <juanitocampamocha@gmail.com>
pkgname=sotw
pkgver=1.1.5
-pkgrel=3
+pkgrel=4
epoch=
pkgdesc="Shadow Of The Wyrm is a single player, traditional roguelike by Julian Day."
arch=('x86_64')
@@ -24,33 +24,29 @@ validpgpkeys=()
build() {
cd shadow-of-the-wyrm
- sed -i -e 's/'"\"SDL2\""'/'"\"SDL2\", \"SDL2_image\""'/g' premake4.lua
git checkout master
+ sed -i -e 's/'"\"SDL2\""'/'"\"SDL2\", \"SDL2_image\""'/g' premake4.lua
premake4 --lua_include=/usr/include/lua5.1 --lua_link=lua5.1 gmake
make config=release
#make config=debug
}
package() {
- echo "cd /usr/share/shadow-of-the-wyrm/sotw" > ${srcdir}/shadow-of-the-wyrm/sotw.sh
- echo "./sotw" >> ${srcdir}/shadow-of-the-wyrm/sotw.sh
+ echo "cd /usr/share/shadow-of-the-wyrm" > ${srcdir}/shadow-of-the-wyrm/sotw.sh
+ echo "./ShadowOfTheWyrm" >> ${srcdir}/shadow-of-the-wyrm/sotw.sh
chmod +x ${srcdir}/shadow-of-the-wyrm/sotw.sh
install -D -m644 ${srcdir}/shadow-of-the-wyrm/LICENSE "${pkgdir}/usr/share/licenses/shadow-of-the-wyrm/LICENSE"
- install -d -m777 ${srcdir}/shadow-of-the-wyrm/sotw "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/howdoi.txt "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/howdoi.txt"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/README.md "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/README.md"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/shadowofthewyrmtext_blank.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/shadowofthewyrmtext_blank.ini"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/shadowofthewyrmtext_en.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/shadowofthewyrmtext_en.ini"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/sotw "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/sotw"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/swyrm.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/swyrm.ini"
+ install -d -m777 ${srcdir}/shadow-of-the-wyrm "${pkgdir}/usr/share/shadow-of-the-wyrm"
install -D ${srcdir}/shadow-of-the-wyrm/ShadowOfTheWyrm "${pkgdir}/usr/share/shadow-of-the-wyrm/ShadowOfTheWyrm"
install -D ${srcdir}/shadow-of-the-wyrm/shadowofthewyrmtext_blank.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/shadowofthewyrmtext_blank.ini"
install -D ${srcdir}/shadow-of-the-wyrm/shadowofthewyrmtext_en.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/shadowofthewyrmtext_en.ini"
install -D ${srcdir}/shadow-of-the-wyrm/swyrm.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/swyrm.ini"
- cp -R ${srcdir}/shadow-of-the-wyrm/sotw/data ${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/data
- cp -R ${srcdir}/shadow-of-the-wyrm/sotw/docs ${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/docs
- cp -R ${srcdir}/shadow-of-the-wyrm/sotw/licenses ${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/licenses
- cp -R ${srcdir}/shadow-of-the-wyrm/sotw/scripts ${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/scripts
- cp -R ${srcdir}/shadow-of-the-wyrm/sotw/texts ${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/texts
+ install -D ${srcdir}/shadow-of-the-wyrm/version_info.txt "${pkgdir}/usr/share/shadow-of-the-wyrm/version_info.txt"
+ cp -R ${srcdir}/shadow-of-the-wyrm/assets ${pkgdir}/usr/share/shadow-of-the-wyrm/assets
+ cp -R ${srcdir}/shadow-of-the-wyrm/data ${pkgdir}/usr/share/shadow-of-the-wyrm/data
+ cp -R ${srcdir}/shadow-of-the-wyrm/docs ${pkgdir}/usr/share/shadow-of-the-wyrm/docs
+ cp -R ${srcdir}/shadow-of-the-wyrm/licenses ${pkgdir}/usr/share/shadow-of-the-wyrm/licenses
+ cp -R ${srcdir}/shadow-of-the-wyrm/scripts ${pkgdir}/usr/share/shadow-of-the-wyrm/scripts
+ cp -R ${srcdir}/shadow-of-the-wyrm/texts ${pkgdir}/usr/share/shadow-of-the-wyrm/texts
install -D ${srcdir}/shadow-of-the-wyrm/sotw.sh ${pkgdir}/usr/bin/sotw
}