summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYoshi28892015-12-30 21:40:21 +0100
committerYoshi28892015-12-30 21:40:21 +0100
commit94cf60d3858da3234b31b1ab044030d6f5a158a3 (patch)
treed67b8df4c44a33c249ca6a1adb9e76341d8effd8 /PKGBUILD
downloadaur-94cf60d3858da3234b31b1ab044030d6f5a158a3.tar.gz
Initial commit
Signed-off-by: Yoshi2889 <rick.2889@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d986e7410b51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Rick Kerkhof <rick.2889@gmail.com>
+pkgname=soundnode-app-bin
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Soundcloud client for the desktop"
+arch=('x86_64' 'i686')
+url="http://www.soundnodeapp.com/"
+license=('GPL3')
+
+# Required, otherwise it won't run.
+options=('!strip')
+
+makedepends=()
+depends=()
+optdepends=()
+
+# I couldn't figure out how to build it properly and the website has no per-release
+# archives. The SHA256sums will fail if it updates; that should be an indication that
+# this package has become out of date.
+source_x86_64=("http://www.soundnodeapp.com/downloads/linux64/Soundnode-App.zip")
+source_i686=("http://www.soundnodeapp.com/downloads/linux32/Soundnode-App.zip")
+
+# Generic sources.
+source=("https://raw.githubusercontent.com/Soundnode/soundnode-app/0.6.1/app/soundnode.png"
+"soundnode-app.desktop")
+
+sha256sums_x86_64=('9cdec26938b3463568f14566f698c619d72c2dff66fc858079df1a89c970527d')
+sha256sums_i686=('807f2d058b5f511129dfd35d22ed874d1cc6fef81a14979e9aef4922bddb4a17')
+
+# Generic checksums.
+sha256sums=('aaae33882ab1e2334b4a33b4235cbdd4beb1379b08f5fa3a0a270f716ea43fa7'
+'c43f90483feeac4fddefc05d535099ea7213f19d890a71f9ad145b7d5c4a9bab')
+
+package() {
+ install -d -m 755 ${pkgdir}/opt/
+ install -d -m 755 ${pkgdir}/usr/share/applications/
+
+
+ install -D -m 644 ${srcdir}/soundnode-app.desktop ${pkgdir}/usr/share/applications/
+
+ rm ${srcdir}/Soundnode-App.zip
+ rm ${srcdir}/soundnode-app.desktop
+ cp -Lr ${srcdir} $pkgdir/opt/${pkgname}
+}