summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Pascal2019-07-15 16:01:57 -0500
committerAndrea Pascal2019-07-15 16:01:57 -0500
commit5f63b528ce914d518726a25f1a3f3a07c189c7a1 (patch)
tree6668465faa57d7a8249b971230c65c6f2c955971 /PKGBUILD
downloadaur-soundscrape-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..661733e30bbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Andrea Pascal <andrea@anodium.net>
+
+pkgname=soundscrape-git
+pkgver=r237.efc63b9
+pkgrel=1
+pkgdesc='SoundCloud (and Bandcamp and Mixcloud) downloader in Python.'
+arch=('any')
+url='https://github.com/Miserlou/SoundScrape'
+license=('Apache')
+
+provides=('soundscrape')
+depends=(
+ 'python'
+ 'python-args'
+ 'python-clint'
+ 'python-demjson'
+ 'python-fudge'
+ 'python-requests'
+ 'python-simplejson'
+ 'python-soundcloud'
+ 'python-wheel'
+ 'python-mutagen'
+)
+makedepends=('git' 'python-setuptools')
+checkdepends=('python-nose')
+
+source=('git+https://github.com/Miserlou/SoundScrape.git')
+sha512sums=('SKIP')
+
+
+build() {
+ cd $srcdir/SoundScrape
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/SoundScrape
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+check() {
+ cd $srcdir/SoundScrape
+ nosetests
+}