summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorimtbl2020-06-14 06:16:23 +0200
committerimtbl2020-06-14 06:16:23 +0200
commitfeba85d6aa512f2bb78044bdc4111cb14612562a (patch)
treed6140f41d128113eddcaf7f4e3bb0b50c839bbba /PKGBUILD
parentf4af1da8024a7f83f09bdcbc595297a7459ac552 (diff)
downloadaur-feba85d6aa512f2bb78044bdc4111cb14612562a.tar.gz
feat: add desktop entry
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3b468c7c060..c836820d820b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
pkgname=soundsense-rs-git
_pkgname=soundsense-rs
pkgver=1.5.1.travis.r8.g055acfb
-pkgrel=1
+pkgrel=2
pkgdesc="A Rust version of SoundSense"
arch=('x86_64')
url="https://github.com/prixt/${_pkgname}"
license=('MIT')
makedepends=('rust' 'alsa-lib' 'gtk3' 'webkit2gtk')
-source=("git+https://github.com/prixt/${_pkgname}.git")
-md5sums=('SKIP')
+source=("git+https://github.com/prixt/${_pkgname}.git"
+ soundsense-rs.desktop)
+sha256sums=('SKIP'
+ 'ced141bf8441d271ee610beebe79cdd5bfe287b1d157d79a7c470d0e44673e5f')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -27,5 +29,9 @@ package() {
cd "${srcdir}/${_pkgname}"
install -Dm755 "target/release/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "icons/icon.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+
+ cd "${srcdir}"
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
}