summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12018-11-26 18:18:25 +0800
committerChocobo12018-11-26 18:18:25 +0800
commit52657e57335808b8e4bed1171c78c2e4697463d5 (patch)
tree5f55df960133c5c80dd598fd69b4990b2061bf76 /PKGBUILD
downloadaur-52657e57335808b8e4bed1171c78c2e4697463d5.tar.gz
newpkg: soundtouch-git 2.1.1.r0.gb9659b6-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cadc9a7521b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=soundtouch-git
+pkgver=2.1.1.r0.gb9659b6
+pkgrel=1
+pkgdesc="Audio tempo/pitch control library"
+arch=('i686' 'x86_64')
+url="https://www.surina.net/soundtouch/"
+license=('LGPL')
+depends=('gcc-libs')
+makedepends=('git')
+provides=('soundtouch')
+conflicts=('soundtouch')
+source=("git+https://gitlab.com/soundtouch/soundtouch.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "soundtouch"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "soundtouch"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "soundtouch"
+
+ make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir/usr/share/doc/soundtouch/COPYING.TXT"
+}