summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorD3SOX2021-03-13 15:44:01 +0100
committerD3SOX2021-03-13 15:44:01 +0100
commit20a8f795460ca1e7d1a3f15da159d501618ff193 (patch)
treed680ab3c17a8d76a60c262d33d236ce203fbe464 /PKGBUILD
parentc1a022aecc9f502402c9a988b28caa4d7935a888 (diff)
downloadaur-20a8f795460ca1e7d1a3f15da159d501618ff193.tar.gz
use upstream install routine
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68a2bb49d6f7..d10e78974e47 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=soundux-git
-pkgver=r424.db04167
-pkgrel=2
+pkgver=r609.556c382
+pkgrel=3
epoch=1
pkgdesc="A cross-platform soundboard"
arch=('any')
@@ -11,8 +11,8 @@ depends=('pulseaudio' 'webkit2gtk')
makedepends=('git' 'cmake' 'ninja')
conflicts=('soundux')
provides=('soundux')
-source=("git+https://github.com/Soundux/Soundux.git" "soundux.desktop")
-sha256sums=('SKIP' '9ba572406c69e23c43ae419fde2bcefb4eade15e4e8ed9c082324b11d7e35184')
+source=("git+https://github.com/Soundux/Soundux.git")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/Soundux"
@@ -31,15 +31,9 @@ build() {
}
package() {
- # install binary
- install -Dm 755 "${srcdir}/Soundux/build/soundux" "${pkgdir}/opt/soundux/soundux"
+ cd "${srcdir}/Soundux/build"
+ DESTDIR="$pkgdir/" ninja install
+ # install binary symlink
mkdir -p "${pkgdir}/usr/bin/"
ln -sf /opt/soundux/soundux "${pkgdir}/usr/bin/soundux"
- # install dist
- mkdir -p "${pkgdir}/opt/soundux/dist"
- cp -r "${srcdir}/Soundux/build/dist"/* "${pkgdir}/opt/soundux/dist"
- # install icon
- install -Dm 664 "${srcdir}/Soundux/assets/icon.png" "${pkgdir}/usr/share/pixmaps/soundux.png"
- # install desktop file
- install -Dm 644 "${srcdir}/soundux.desktop" "${pkgdir}/usr/share/applications/soundux.desktop"
}