summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBehnam Momeni2016-06-29 12:44:19 +0430
committerBehnam Momeni2016-06-29 12:44:19 +0430
commit96004e636cd0d4870cd161276f4b95ce89fbc663 (patch)
treef700ea1b3f5602d547a48f6e00296719d4446a73 /PKGBUILD
parent8643e4faadd304b365a55d26293260c685ae04b9 (diff)
downloadaur-96004e636cd0d4870cd161276f4b95ce89fbc663.tar.gz
Supporting rebuild in an already built folder
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 813fd675eb0e..10d3ace659a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgver=16.02
# the build version is obtained from [here](https://github.com/senshu/Sozi/releases)
_buildver=16.02.141048
_pkgverpostfix="-fix344" # this is required because the pkgver cannot contain hyphen
-pkgrel=2
+pkgrel=3
pkgdesc="A zooming presentation based on SVG, using JavaScript"
url="http://sozi.baierouge.fr/"
@@ -135,6 +135,7 @@ build() {
done
cd "${srcdir}/Sozi-${pkgver}${_pkgverpostfix}/"
+ rm -rf "build"
rm -rf "node_modules"; mkdir "node_modules"
cat package.json | jq -r '.dependencies, .devDependencies | to_entries? | map(.key + "@" + .value) | .[]' | sort -u | while read dep; do
local package="$(echo "$dep" | gawk -F'@' '{ print $1 }')"