summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0xNim2023-07-11 11:22:47 +0300
committer0xNim2023-07-11 11:22:47 +0300
commit48e176580aadd1aaada7fe45ffd10e6792d14667 (patch)
tree40ed5e827d37b983574a27a74eae2c33956b6644 /PKGBUILD
downloadaur-48e176580aadd1aaada7fe45ffd10e6792d14667.tar.gz
Initial Creation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59a72e546721
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Niklas Wojtkowiak <aur.7xcqe@passmail.com>
+_pkgname='spacedrive'
+_upkgname='Spacedrive'
+pkgname="${_pkgname}-bin"
+pkgver='2023.1.0'
+pkgrel=1
+pkgdesc="A file manager from the future."
+arch=('x86_64')
+url="https://spacedrive.com"
+_url_source='https://github.com/Nim1com/spacedrive'
+license=('AGPL3')
+providers=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("$_url_source/releases/download/desktop@${pkgver}/data.tar.xz")
+sha256sums=('8df5efae0fa10b72eb129e76f02a9156267c2d7799d29052cfdac5593773390c')
+
+package() {
+
+ install -dv "${pkgdir}/usr/bin"
+ ln -sfv "/opt/${_upkgname}/${_pkgname}" -t "${pkgdir}/usr/bin"
+}
+