summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Campbell2020-06-03 19:16:29 -0500
committerDan Campbell2020-06-03 19:16:29 -0500
commit0fa89e0ee6a55f64945c18ba101a244695c037c5 (patch)
treee70c7355fe0ef3a6ebc63f051e6bd7900f63b636 /PKGBUILD
parent75bb757f593e6a7b38f9dce6bdff916f3778278d (diff)
downloadaur-0fa89e0ee6a55f64945c18ba101a244695c037c5.tar.gz
Update to spacenavd-0.7.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8264d2a7a47d..2aded1fd5621 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+# Maintainer: Dan Campbell <dan at compiledworks dot com>
+# Former Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
# Creator: Jan Hambrecht <jaham at gmx dot net>
pkgname=spacenavd
-pkgver=0.7
-pkgrel=2
+pkgver=0.7.1
+pkgrel=1
pkgdesc="The spacenav project provides a free, compatible alternative, to the proprietary 3Dconnexion device driver and SDK, for their 3D input devices (called 'space navigator', 'space pilot', 'space traveller', etc)."
arch=('x86_64')
url="http://spacenav.sourceforge.net/"
@@ -13,18 +14,18 @@ provides=('spacenavd')
backup=('etc/spnavrc')
source=(https://github.com/FreeSpacenav/spacenavd/releases/download/v$pkgver/spacenavd-$pkgver.tar.gz spacenavd.service)
-sha256sums=('d2493c8124c0e615e7b9bc28cbc1fb7cb1ebc2670c8af86745dedc7e142fafce'
+sha256sums=('9266e19b847dabc79bac0f16984e6104338021f83c784780e2fb569c41529d2b'
'5a1122cf44acdf34537bc2ef7c1ad3776872f335b2993d68833c23f999d96c11')
build() {
cd ${pkgname}-${pkgver}
./configure --prefix=/usr
- make || return 1
+ make
}
package() {
cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install || return 1
- install -D -m644 ${srcdir}/spacenavd.service ${pkgdir}/etc/systemd/system/spacenavd.service || return 1
- install -D -m644 ${srcdir}/$pkgname-$pkgver/doc/example-spnavrc ${pkgdir}/etc/spnavrc || return 1
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 ${srcdir}/spacenavd.service ${pkgdir}/etc/systemd/system/spacenavd.service
+ install -D -m644 ${srcdir}/$pkgname-$pkgver/doc/example-spnavrc ${pkgdir}/etc/spnavrc
}