summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-07-01 20:09:33 +0900
committerBenjamin Chrétien2015-07-01 20:09:33 +0900
commit067e5d667aa86ad1102940f215c5342156f52d15 (patch)
tree6c4f483c583efd373b48807d74156948054224db /PKGBUILD
parent0a6a6d1f0646ab9fe9eff814e754024f8e60f7db (diff)
downloadaur-067e5d667aa86ad1102940f215c5342156f52d15.tar.gz
Fix eigen3topython dependency + re-enable tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e38073d13a0..876337277ab5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=spacevecalg-git
_name=spacevecalg
-pkgver=20150621
+pkgver=20150701
pkgver() {
date +%Y%m%d
}
@@ -11,9 +11,8 @@ pkgdesc="Implementation of spatial vector algebra with the Eigen 3 linear algebr
arch=('i686' 'x86_64')
url="https://github.com/jorisv/SpaceVecAlg"
license=('GPLv3')
-depends=('eigen3' 'python2')
-makedepends=('doxygen' 'cmake' 'git' 'pkg-config' 'boost'
- 'python2-pybindgen' 'eigen3topython')
+depends=('eigen3' 'python2' 'eigen3topython')
+makedepends=('doxygen' 'cmake' 'git' 'pkg-config' 'boost' 'python2-pybindgen')
provides=('spacevecalg')
source=("${_name}::git+https://github.com/jorisv/SpaceVecAlg")
md5sums=('SKIP')
@@ -36,11 +35,11 @@ build()
make
}
-#check()
-#{
-# cd ${srcdir}/build
-# make test
-#}
+check()
+{
+ cd ${srcdir}/build
+ make test
+}
package()
{