summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Schubert2020-05-21 10:57:37 +0200
committerSimon Schubert2020-05-21 10:57:37 +0200
commite439ffe2e84e55a861a2f69b5e5a2900d777da2b (patch)
tree03af8661d2cd8a8fedd235bbb739a072191cd70f /PKGBUILD
parent3cf472cbc8d1219bf0ce528e9317d772b8ca2358 (diff)
downloadaur-e439ffe2e84e55a861a2f69b5e5a2900d777da2b.tar.gz
update to gcc 10.1/gnat 2020
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b9d35daa8cc..19a657c5fb6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=spark2014-git
-pkgver=0.3.draft.r17853.g7a0a54649
+pkgver=0.3.draft.r19318.g3559419bef
pkgrel=1
pkgdesc='formally defined programming language based on ada (gnat fsf)'
@@ -9,7 +9,7 @@ license=('GPL')
options=('!makeflags')
-depends=('gprbuild' 'python')
+depends=('gprbuild' 'python2')
makedepends=('git' 'coq' 'gnatcoll-core' 'gprbuild' 'ocaml-num' 'ocaml-menhir'
'ocaml-ocamlgraph' 'ocaml-zarith' 'ocaml-camlzip'
'ocaml-ocplib-simplex' 'python-sphinx')
@@ -27,17 +27,20 @@ conflicts=('spark2014' 'why3')
source=('git+https://github.com/AdaCore/spark2014#branch=fsf'
'why3-adacore::git+https://github.com/AdaCore/why3'
'git+https://github.com/gcc-mirror/gcc'
- 'makefile-installdir-fixes.diff')
+ 'makefile-installdir-fixes.diff'
+ 'why3-menhirLib-fix.diff')
sha256sums=('SKIP' 'SKIP' 'SKIP'
- '2820a309db93782af029ba5b8492379e7aa2c58350629def00f748123866f3dd')
+ 'fa399eab4d3acaf73158ebb5774c8b5d4421ef8a86a31bc8232bc0f16af8cf2f'
+ '8bcf62beb5773a6da910a512d8384343774aa3561d6d5b5c1891e545aef635aa')
prepare() {
cd spark2014
git submodule init
git config submodule.why3.url "$srcdir"/why3-adacore
git submodule update why3
+ cd why3 && git reset --hard && cd ..
ln -sf "$srcdir"/gcc/gcc/ada gnat2why/gnat_src
@@ -45,6 +48,8 @@ prepare() {
# houring the INSTALLDIR convention used within this Makefile.
patch -Np1 -i "$srcdir"/makefile-installdir-fixes.diff
+ patch -Np1 -i "$srcdir"/why3-menhirLib-fix.diff
+
# Arch Linux doesn't use libexec, everything lives under lib.
sed -i 's/libexec/lib/g' gnatprove/configuration.ads
}
@@ -56,7 +61,7 @@ pkgver() {
build() {
cd spark2014
- make setup
+ make setup INSTALLDIR="$pkgdir"/usr
make
make -C docs/lrm man
make -C docs/ug man
@@ -81,7 +86,7 @@ package() {
# For some reason the spark install doesn't include the why3 drivers and
# the other bits which gnatprove needs to function.
- cp -a --no-preserve=ownership install/share/why3 "$pkgdir"/usr/share
+ # cp -a --no-preserve=ownership install/share/why3 "$pkgdir"/usr/share
# Needed?
# install -Dm0755 install/bin/why3cpulimit "$pkgdir"/usr/lib/spark/bin/why3cpulimit