diff options
author | Narrat | 2023-11-06 23:50:25 +0100 |
---|---|---|
committer | Narrat | 2023-11-06 23:50:25 +0100 |
commit | f51d629d2409044c3c5917f54e8d6f130092a5a1 (patch) | |
tree | 4c0d8ac16069bc42541ecf0121b6a9fdecf4cfc0 /PKGBUILD | |
parent | a756b863ab70f8dcbe14e1d5a6f8c7220eeed39c (diff) | |
download | aur-f51d629d2409044c3c5917f54e8d6f130092a5a1.tar.gz |
sparta: fix package creation
The following issue was reported by peshev:
The find command in the package() function of the PKGBUILD installs all the files in /usr/share/sparta flat (without the directory hierarchy) - which means the imports in the scripts don't work poperly
And peshev supplied this patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -1,10 +1,11 @@ +# Contributor: peshev <> # Contributor: FFY00 <filipe.lains@gmail.com> # Contributor: Cyberpunk <aur_linuxero@outlook.com> pkgname=sparta pkgver=2.0.0 _commit=d95993d283d69eb76d30565cea6ad49976685b5f -pkgrel=1 +pkgrel=2 pkgdesc='Python GUI application which simplifies network infrastructure penetration testing.' arch=('any') url="https://github.com/SECFORCE/sparta" @@ -25,7 +26,7 @@ package() { install -dm 755 "$pkgdir"/usr/bin/ install -dm 755 "$pkgdir"/usr/share/$pkgname - find $pkgname -type f -exec install -m 644 "{}" "$pkgdir"/usr/share/$pkgname \; + find $pkgname -type f -not -path '*/.git*' -exec install -D -m 644 "{}" "$pkgdir"/usr/share/{} \; install -Dm 755 sparta_launcher "$pkgdir"/usr/bin/sparta } |