summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamuel Mesa2018-10-21 18:13:00 -0500
committerSamuel Mesa2018-10-21 18:13:00 -0500
commitb42b794080f5a7050a26747f72b983995817272a (patch)
treebca32bd44fe970eec0ab7e8c99d57e8a6c166e75 /PKGBUILD
parent5b94d30fcd711e69d919de77ed2d15a75123a13f (diff)
downloadaur-b42b794080f5a7050a26747f72b983995817272a.tar.gz
Update version 2.1.0-beta0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa90b301f639..8b64e64a4c81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,34 @@
# Contributor: snork
pkgname=spatialite-gui-devel
-pkgver=2.0.0
-pkgrel=3
+pkgver=2.1.0
+_pkgver=2.1.0-beta0
+pkgrel=1
pkgdesc="spatialite-gui is an open source Graphical User Interface (GUI)
tool supporting SpatiaLite. Development version"
url="https://www.gaia-gis.it/fossil/spatialite_gui/index"
arch=('x86_64' 'i686')
license=('GPLv3')
-depends=('libspatialite>=4.1.1-3' 'librasterlite2-devel' 'wxgtk' 'openjpeg2=2.1.2')
+depends=('libspatialite-devel' 'librasterlite2-devel' 'virtualpg2-devel' 'wxgtk' 'openjpeg2')
conflicts=(spatialite-gui)
replaces=(spatialite-gui)
-source=("http://www.gaia-gis.it/gaia-sins/spatialite-gui-sources/spatialite_gui-${pkgver}-devel.tar.gz"
- patch01_pointer.patch)
+source=("http://www.gaia-gis.it/gaia-sins/spatialite-gui-sources/spatialite_gui-${_pkgver}.tar.gz")
_pkgname=spatialite_gui
-md5sums=('2ad2936e34923029b9b6cd94c428066c'
- 'd3ae41d66f29d838089221dc793ee95e')
-
-prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}-devel"
- patch -p0 < ../patch01_pointer.patch
-}
+md5sums=('f06289fa547e596d9c01c23c5e1722ec')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}-devel"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
+
+ ./configure --prefix="/usr" \
+ CXXFLAGS="`wx-config --version=3.0 --cxxflags`" \
+ LIBS="`wx-config --version=3.0 --libs`"
- ./configure --prefix="/usr"
- make -j3
+ make -j4
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}-devel"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
make DESTDIR="${pkgdir}" install
install -D -m644 gnome_resource/spatialite-gui.desktop "${pkgdir}"/usr/share/applications/spatialite-gui.desktop
install -D -m644 gnome_resource/spatialite-gui.png "${pkgdir}"/usr/share/pixmaps/spatialite-gui.png