summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbrent s2016-04-03 03:17:33 -0400
committerbrent s2016-04-03 03:17:33 -0400
commit88979e60bcf9a398357732ebae6494ff8f581862 (patch)
tree39a05679f7213415ecd4b667eafd476957225c6b /PKGBUILD
parent28073c48de58b56bf398007e1dd62ac12e6a6309 (diff)
downloadaur-88979e60bcf9a398357732ebae6494ff8f581862.tar.gz
fixing some issues with AUR helpers
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1feda2220d5a..32933d8f7955 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=spearmint
pkgver=0.2
-pkgrel=3
+pkgrel=4
pkgdesc="An improved ioquake3-based Quake 3: Arena client (note: requires pak files from original CD)"
url="http://spearmint.pw"
license=("GPL3")
@@ -27,6 +27,8 @@ build() {
mv "${pkgname}-${pkgver}-linux" ${pkgname}
cd ${pkgname}
+if [ ! -f "${pkgname}-server" ];
+then
if [[ "${CARCH}" == 'i686' ]];
then
rm -f ${pkgname}{,-server}_x86_64
@@ -40,6 +42,7 @@ build() {
mv ${pkgname}-server_x86_64 ${pkgname}-server
_ARCH=${CARCH}
fi
+fi
mv ${pkgname}-${pkgver}-readme.txt readme.txt
}