summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbitcoinlizard2023-03-21 22:26:56 -0500
committerbitcoinlizard2023-03-21 22:26:56 -0500
commit696194d6a612e0063bb2c5480d51246131262497 (patch)
tree91738d9106b2e4b6062fb78f585f5c6a6b5228cc /PKGBUILD
parentd6783ac86b6f8cb737816545411f65d2c32f3f2e (diff)
downloadaur-696194d6a612e0063bb2c5480d51246131262497.tar.gz
upgpkg: specter-desktop 2.0.0: upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aab6048ec11c..4a6b0e22812f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,37 @@
# Maintainer: bitcoinlizard <bitcoinlizard at fastmail dot com>
pkgname=specter-desktop
-pkgver=1.14.5
+pkgver=2.0.0
pkgrel=1
pkgdesc="Specter Desktop functions as a watch-only coordinator for multi-signature and single-key Bitcoin wallets."
arch=('any')
url="https://specter.solutions"
license=('MIT')
makedepends=('python-setuptools')
-depends=('python' 'libusb' 'systemd-libs' 'python-dotenv' 'python-flask' 'python-flask-login' 'python-flask-wtf' 'python-mnemonic' 'python-hwilib' 'python-embit' 'python-flask-cors' 'python-pgpy' 'python-pyopenssl' 'python-stem'
-'python-typing_extensions' 'python-psutil' 'python-hidapi' 'python-ecdsa' 'python-protobuf' 'python-importlib-metadata' 'python-daemonize' 'python-noiseprotocol-git' 'python-wheel' 'python-pyasn1' 'python-cbor' 'python-urllib3' 'python-flask-babel' 'python-flask-apscheduler' 'gunicorn' 'python-cryptography' 'python-pyjwt' 'specterext-exfund' 'specterext-faucet' 'specterext-liquidissuer' 'specterext-spectrum')
+depends=('python' 'python-aniso8601' 'python-apscheduler' 'python-babel' 'python-base58' 'python-bitbox02' 'python-cbor' 'python-certifi' 'python-cffi' 'python-chardet' 'python-charset-normalizer' 'python-click' 'python-cryptography' 'python-ecdsa' 'python-embit' 'python-flask' 'python-flask-apscheduler' 'python-flask-babel=2.0.0' 'python-flask-cors' 'python-flask-httpauth' 'python-flask-login' 'python-flask-restful' 'python-flask-sqlalchemy' 'python-flask-wtf' 'python-greenlet' 'gunicorn' 'python-h11' 'python-hidapi' 'python-hwilib' 'python-idna' 'python-itsdangerous' 'python-jinja' 'python-libusb1' 'python-markupsafe' 'python-mnemonic' 'python-noiseprotocol-git' 'python-numpy' 'python-pandas' 'python-pgpy' 'python-plotly' 'python-protobuf' 'python-psutil' 'python-psycopg2' 'python-pyaes' 'python-pyasn1' 'python-pycparser' 'python-pyjwt' 'python-pyopenssl' 'python-pyserial' 'python-pysocks' 'python-dateutil' 'python-dotenv' 'python-pytimeparse' 'python-pytz' 'python-pytz-deprecation-shim' 'python-requests' 'python-semver' 'python-simple-websocket' 'python-six' 'python-sqlalchemy' 'python-stem' 'python-tenacity' 'python-typing-extensions' 'python-tzdata' 'python-tzlocal' 'python-urllib3' 'python-werkzeug' 'python-wsproto' 'python-wtforms' 'python-importlib-metadata' 'python-daemonize' 'python-wheel' 'specterext-exfund' 'specterext-faucet' 'specterext-liquidissuer' 'specterext-spectrum' 'specterext-stacktrack')
backup=(usr/lib/systemd/system/specter.service)
install=$pkgname.install
source=("https://github.com/cryptoadvance/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
'specter.service'
- 'version.patch'
'specter-desktop.install')
-sha256sums=('593505f3efb337989e34f856a66d54928dc91ebf951fd3f3717e43110d014354'
+sha256sums=('6728741e013669711a2c2267f061a09e6c77c1452dfca3d6d18988fa36ba6ac4'
'9b5f57a0ebd48e6b7d1ac240913e4b502a6e3ffc5b64ff87ed263f1a4810a265'
- 'b9f9d621815436c2f7e742b36ea76eeecdbbbd1678d8484acc08d35998210b41'
'668ace7f14369014e42197321fa7e0edc90737c87e2b6a68354ab205d37e3aa6')
-prepare() {
- cd "${pkgname}-${pkgver}"
- patch --forward --strip=1 --input="${srcdir}/version.patch"
-}
-
build() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
cd "${pkgname}-${pkgver}"
- python setup.py sdist bdist_wheel
+ python setup.py build
}
package() {
cd "${pkgname}-${pkgver}"
-
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python setup.py install --root="$pkgdir" --optimize=1
# install systemd file
install -Dm 644 "${srcdir}"/*.service -t "${pkgdir}"/usr/lib/systemd/system
# Install license since the package doesn't include it
install -Dm 644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
}