summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbitcoinlizard2021-07-18 20:22:44 -0500
committerbitcoinlizard2021-07-18 20:22:44 -0500
commit870f1bfabac2f34d39293e5ec39a5f1a309cc229 (patch)
treee4a46f206b75990d7a87f9f9df5969cbfea6f5d9 /PKGBUILD
parentd6d111bd05696e47257941e6e9fb3e89e619d798 (diff)
downloadaur-870f1bfabac2f34d39293e5ec39a5f1a309cc229.tar.gz
updated to version 1.5.0, removed patch as issue has been resolved upstream in version 1.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f087f0bd42a..4b247b80fc77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: bitcoinlizard <bitcoinlizard@fastmail.com>
+# Maintainer: bitcoinlizard <bitcoinlizard at fastmail dot com>
pkgname=specter-desktop
-pkgver=1.4.6
+pkgver=1.5.0
pkgrel=1
pkgdesc="Specter Desktop functions as a watch-only coordinator for multi-signature and single-key Bitcoin wallets."
arch=('any')
@@ -9,22 +9,19 @@ url="https://specter.solutions"
license=('MIT')
makedepends=('python-setuptools')
depends=('python' 'libusb' 'systemd-libs' 'python-dotenv' 'python-flask' 'python-flask-login' 'python-flask-wtf' 'python-mnemonic' 'python-hwilib' 'python-embit' 'python-flask-cors' 'python-pgpy' 'python-pyopenssl' 'python-stem'
-'python-typing_extensions' 'python-psutil' 'python-hidapi' 'python-ecdsa' 'python-protobuf' 'python-importlib-metadata' 'python-daemonize' 'python-noiseprotocol-git' 'python-wheel' 'python-pyasn1' 'python-cbor' 'python-urllib3')
+'python-typing_extensions' 'python-psutil' 'python-hidapi' 'python-ecdsa' 'python-protobuf' 'python-importlib-metadata' 'python-daemonize' 'python-noiseprotocol-git' 'python-wheel' 'python-pyasn1' 'python-cbor' 'python-urllib3' 'python-flask-babel')
source=("https://github.com/cryptoadvance/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
'specter.service'
- 'version.patch'
- 'sign.patch')
+ 'version.patch')
-sha256sums=('b6c0b439bb11961516ab5002c2cc86d37e4923fc3dc0ed8d64b2f96342dc519f'
+sha256sums=('c90a142bd34a4e9b8d0cf4339fc9209937121c8faef8a0f8ccc52750cab4c8a7'
'9b5f57a0ebd48e6b7d1ac240913e4b502a6e3ffc5b64ff87ed263f1a4810a265'
- '2f18621d0a68a1d2b5686a9c002a8013483060920a0bfa86df7caf652a8be05e'
- '839d2577e81c963e1c35837d4fe1536aa9306ba00b835057d0209f373efff2c1')
+ '0c5c86c0109b096b7076fcb82817db63fcda2f5cc42ce0eb70ffa7fac06203e6')
prepare() {
cd "${pkgname}-${pkgver}"
patch --forward --strip=1 --input="${srcdir}/version.patch"
- patch --forward --strip=1 --input="${srcdir}/sign.patch"
}
build() {