summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbitcoinlizard2021-06-27 17:34:29 -0500
committerbitcoinlizard2021-06-27 17:34:29 -0500
commitbe4952eccd792ac13bc4d2cd9c090c4c90019701 (patch)
treeb04abad2e305d72fc679e16cdbb8b2e799294da5 /PKGBUILD
parent871a921064369753680e011db777e78049556396 (diff)
downloadaur-be4952eccd792ac13bc4d2cd9c090c4c90019701.tar.gz
updated to version 1.4.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96ba54eb4fa9..b86b782c27f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,32 @@
# Maintainer: bitcoinlizard <bitcoinlizard@fastmail.com>
pkgname=specter-desktop
-pkgver=1.3.1
+pkgver=1.4.5
pkgrel=1
-pkgdesc="Specter Desktop functions as a watch-only coordinator for multi- signature and single-key Bitcoin wallets."
+pkgdesc="Specter Desktop functions as a watch-only coordinator for multi-signature and single-key Bitcoin wallets."
arch=('any')
url="https://specter.solutions"
license=('MIT')
makedepends=('python-setuptools')
-depends=('python' 'libusb' 'systemd-libs' 'python-dotenv' 'python-flask' 'python-flask-login' 'python-flask-wtf' 'python-mnemonic' 'python-hwilib' 'python-embit' 'python-flask-cors' 'python-pgpy' 'python-pyopenssl' 'python-stem' 'python-typing_extensions' 'python-psutil' 'python-hidapi' 'python-ecdsa' 'python-protobuf' 'python-importlib-metadata')
+depends=('python' 'libusb' 'systemd-libs' 'python-dotenv' 'python-flask' 'python-flask-login' 'python-flask-wtf' 'python-mnemonic' 'python-hwilib' 'python-embit-git' 'python-flask-cors' 'python-pgpy' 'python-pyopenssl' 'python-stem'
+'python-typing_extensions' 'python-psutil' 'python-hidapi' 'python-ecdsa' 'python-protobuf' 'python-importlib-metadata' 'python-daemonize' 'python-noiseprotocol-git' 'python-wheel' 'python-pyasn1' 'python-cbor')
source=("https://github.com/cryptoadvance/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
- 'specter.service')
-sha512sums=('c0aa9fe9088160b0275cc713d024f906c63c2fbc22458cb729efcd2c7b5c6c4b746a80cb24be34962054283ac70bd44d8a9b314071c911c924eb79fa7210b073'
- '2225d9b70c01c0a8306144926641e4ba7f39aef508cf3a1fbac13accac3319e29272ea42105e7a5020bba5721a0c26e8ebc0aeacec26047458e6fe3d6729525a')
+ 'specter.service'
+ 'version.patch')
+
+sha256sums=('c485931607fd8a063c494c8bbe4e888b62bc17eff78c0aec4eb817f06e5848a5'
+ '9b5f57a0ebd48e6b7d1ac240913e4b502a6e3ffc5b64ff87ed263f1a4810a265'
+ 'ec0994d82f71abbe62e0a40c1f084a1718aded9e77cca63b41e4c400c9eb7962')
prepare() {
cd "${pkgname}-${pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/version.patch"
}
build() {
cd "${pkgname}-${pkgver}"
-
- python setup.py build
+ python setup.py sdist bdist_wheel
}
package() {